...

View Full Version : ie/win css issue



Pmumford
02-16-2008, 06:50 PM
Hi,

I'm trying to bug fix some css issues in IE/Win. Sites look great on firefox/safari but my menu bar doesn't seem to float properly in ie. It may well be bad code, or a ie bug, but i don't know where to start trying to fix it.
I've been reading up about lots of float issues with ie, but identifying the problem aint been easy. I was hoping someone with more experience might be able to give me a pointer or two.

The site can be viewed here:

http://www.atticusfinch.tv/core2/

If you can help, please do!

Ta,

paul

CFMaBiSmAd
02-16-2008, 06:59 PM
This site you posted contains 14 html validation errors and 11 css errors. Fix those first, then worry about how the page works in different browsers -

http://validator.w3.org/check?uri=http%3A%2F%2Fwww.atticusfinch.tv%2Fcore2%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fwww.atticusfinch.tv%2Fcore2%2F&warning=1&profile=css21&usermedium=all

Pmumford
02-16-2008, 09:37 PM
Hi,

Thanks. I've managed to get the css vaildated no probs, having a few probs with one section of code on the html validation though.

I need to embed a quicktime. Originally i was using an embed tag, but have switched to the object tag in order to have it vaildate properly. However it both doesnt validate or load the quicktime properly now and i'm confused as to how to get this last bit sorted before tackling the css.

I need to grab the name of the quicktime dynamically from a database [had this working ok before with the embed tags] so i don't know if this is whats screwing it up or if i've missed something else?


This is the trouble code:

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" codebase="http://www.apple.com/qtactivex/qtplugin.cab" width="512" height="310">

<?php echo c2c_get_custom('QT', '<param name="video/quicktime" value="http://www.atticusfinch.tv/corevideo/', '.mov"/>', ''); ?>
<param name="controller" value="true" />
<param name="autoplay" value="false" />
!--[if !IE]>-->
<?php echo c2c_get_custom('QT', '<object type="video/quicktime"data="http://www.atticusfinch.tv/corevideo/', '.mov" autoplay="false" width="512" height="310" />', ''); ?>
<param name="autoplay" value="true" />
<param name="controller" value="true" />
</object>
<!--<![endif]-->
</object>


Thanks,

Paul

Pmumford
02-17-2008, 11:43 AM
ok ok, i've fixed that last bit by switching to a javascript technique, so the page now validates as xhtml and the css is ok.

So back to original problem... can anyone help me with my float problem where my menu sticks halfway down the page in ie/win?

Thanks,

Paul

Pmumford
02-17-2008, 05:46 PM
nevermind, on the road to fixing now.

Thanks



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum