View Full Version : CSS and IE

01-15-2008, 01:34 AM
Having a bit of a problem with a hack for IE.

In FF site displays fine, but IE6 and IE7 both have the same issue. Once you load the website you will see the problem.


If anyone has a suggestion, please post.


01-15-2008, 02:25 AM
At first it gets: Failed validation

So I change Encoding to iso-8859-1 (Western European) and get Failed validation, 115 Errors (http://validator.w3.org/check?uri=http%3A%2F%2Fwww.newsdots.com%2Fanswers%2F&charset=iso-8859-1&doctype=Inline&group=0&verbose=1)

Some of those errors are critical and might be causing your problems.

01-15-2008, 09:14 AM
I can't quite put my finger on it, but there's seems to be a hell of a lot of code there and not much content on the page at all. I think you need to look at your output and try to optimise it a little because at the moment there's plenty of stuff that doesn't look like it needs to be there, or could be condensed

01-15-2008, 09:35 AM
I looked at this again...

Viewing these changes in FireFox,
-change the color on #wrapper like this: #wrapper{background:#000;text-align:left;position:relative} you can see it's not wrapping. You need to clear your floats.
Make it read like this: #wrapper{background:#000;text-align:left;position:relative;overflow: auto;} and you'll see what I mean.

Here's a link explaining the overflow:auto; clearing method (http://www.quirksmode.org/css/clearing.html).

Looks like #page and #spellify have the same problem. Since your #user-summary, .user-image and user-profiles are all floated it may be that not clearing floats is your problem...

01-15-2008, 11:22 AM
I have read the tutorial and made a few changes, and made some progress, but it still isn't 100%.

Can you look again and advise?


01-15-2008, 07:41 PM
Ok, the issue is solved, I changed this:



#user-summary{float:left; clear:both;}

and it now works.