View Full Version : Dropdown menu items - partial area activation

01-08-2008, 05:57 AM
Apologies in advance as I'm sure this has been answered before but my searches don't find me a solution.

I have a very basic dropdown menu based on Suckerfish, all validates ok and the hover bugfix for IE seems fine.


Problem is when I rollover the dropdown items from the "photographers" menu, only part of the items area activates the links. The bottom area of each list item (except the last) fails to activate.

Perhaps the problem lies in the border widths of the dropdown items, but I'm only guessing, and adjustments seem not to have fixed it.

Any advice gratefully appreciated.

I also wonder if someone could confirm the menu is working correctly in IE7.


01-08-2008, 07:09 AM
Hello pavinder,
I thought it was working fine in IE7 until I clicked on Contact.
When on the contact page the dropdown under Photographers is partially covered by the darker color behind Contact.
Did that make sense?

It worked perfectly on the other pages.

01-08-2008, 07:20 AM
Thanks for letting me know. Not sure exactly what you mean but will check and do some debugging.

Still looking for help re. my main original problem of rollover deactivations.

Thanks in advance for any suggestions.

01-09-2008, 12:51 PM
Can anybody suggest if this non-activation problem might be a simple width/height or position tweak (I've tried various adjustments to no avail) or whether it may be more likely due to nesting or overlap of divs?

Just not sure where to start adjusting now.


01-15-2008, 06:02 AM
Really could use some guidance here - please?

If I use the Firefox Web Developer addon to show Outline>Positioned Elements>Relative, the dropdown menu displays outlines as "overlapped". In other words the outline is not matched to the element displayed.
The css definition (in menu.css) shows:

#nav li li a {
display: block;
width: 133px;
position: relative; top: 7px;
font-family: Helvetica, Arial, Verdana, sans-serif;
font-size: 12px;
font-style: normal;
font-weight: normal;
text-transform: none;
line-height: 160%;
color: #f0f0f0;
background-color: #bcc0e6;
padding: 0;
border-style: solid;
border-color: #ffffff;
border-width: 1px 2px 1px 2px;

#nav li li a:hover {
width: 125px;
position: relative; top: 7px;
background-color: #999ed6;
border-width: 1px 6px;

It seems the Outlined area is ignoring the "top" distance and therefore not corresponding to the actual item displayed.
If I modify the "top" number of pixels (in both the a and a:hover), the area of the items which deactivates on rollover changes accordingly, and corresponds to the new areas where the Outline mismatches the element.

Completely baffled. What could be causing this??