...

View Full Version : My site not displaying properly in Opera . NOW RESOLVED.



effpeetee
12-31-2007, 10:45 AM
My site not displaying properly in Opera.

http://exitfegs.co.uk/Sources.html

Has a dropped centre column in Opera but is OK in IE7 and FFox2.
Is there a hack or is there a mistake in my code. (not unusual)

Help appreciated,

Frank

EDIT- Since doing the suggestd mods, it will not now display properly in Firefox 2.0.0.11

Arbitrator
12-31-2007, 12:24 PM
My site not displaying properly in Opera.

http://exitfegs.co.uk/Sources.html

Has a dropped centre column in Opera but is OK in IE7 and FFox2.
Is there a hack or is there a mistake in my code. (not unusual)Well, before submitting your code to the forum, you may want to validate it [1]. There’s a missing </ul> tag at the end of the #content1 element.

I would also check your measurements. I note that you’re using percentages in conjunction with pixels; across the three columns, you have them taking up 96% (32% × 3) of the available horizontal space in content width and 30 pixels (5 pixels × 6) in left and right padding. If the remaining 4% of horizontal space happens to be less than 30 pixels wide, then the middle column would have to fall. The remaining horizontal space is dependent upon the size of the viewport, which is affected by window size, screen resolution, monitor size, et cetera; personally, I would avoid percentage‐pixel combinations.

Finally, I see the center column drop in Mozilla Firefox 2.0.0.11; this is contrary to your claim. It also drops in Windows Internet Explorer 7.0.5730.13 if I decrease the size of the window to a certain point.


http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fexitfegs.co.uk%2FSources.html

effpeetee
12-31-2007, 12:42 PM
I will tidy up the &#37;/px issue,



HELP

Frank



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum