...

View Full Version : Apache installation problem



saeed
12-10-2007, 07:41 AM
Hello,

For the first time I am trying to install apache http server I've got "apache_2.0.59-win32-x86-no_ssl.msi" file. Now everything was going fine and just before finish I got some errors. I've got there screenshots which are uploaded at

www.htcpak.com/saeed/error1.jpg (http://www.codingforums.com/www.htcpak.com/saeed/error1.jpg)
www.htcpak.com/saeed/error2.jpg (http://www.codingforums.com/www.htcpak.com/saeed/error2.jpg)

and after installation there is a msg on taskbar "No services installed" when i mouse-over at apache server

I am using Windows XP Service Pack 2 and I've got obtain IP automatically in TCPIP settings.

It will be very much appreciated if anyone respond this query asap.

Thank you very much indeed,


Saeed

CFMaBiSmAd
12-10-2007, 12:19 PM
The two links in your post don't work (they have the URL of this forum prepended to them.)

However, the first error means you already have a service listening on port 80. This prevented the Apache web server from being installed, which is what caused the second error message.

If you already have an existing web server installed, your best choice would be to remove it if you don't want to continue using it or stop it from running. You can then try to reinstall Apache.

saeed
12-10-2007, 12:50 PM
thanks very much for your reply,

well I tried it after uninstalling the previous one but again having the same error... now I have downloaded xampp-win32-1.6.4-installer.exe .. installation was fine .. but apache isn't working it was giving me error of port 80 is in use.. I havn't installed apache server separately.

In XWAPP control panel I cannot start Apache services

hope this screen shot helps.

thanks for your reply anyway,


Saeed.

saeed
12-10-2007, 12:54 PM
is there anything to do with IP coz I dont have static IP on this machine. and yeah I am using Windows XP Pro with SP2 and Network Magic.

It would be appreciated if you can elaborate between XWAMPP and 'installing softwares separately'.


Thank you very much.

abduraooft
12-10-2007, 01:46 PM
Do you have Skype or something like running in your system.
Then turn them off(exit) and install/start xamp. After that you can turn on the previously closed programs!

saeed
12-11-2007, 04:55 AM
Thanks for our reply abduraooft

No I don't have Skype on this computer.

I've got Network Magic and AVG Antivirus running (taskbar)

If I've to find out which program is using Port 80 how can I do that and how to change port?

saeed
12-11-2007, 06:21 AM
I tried it again after turning off Network Magic... and its working fine.

but how can I change my Port if i want to run Network Magic and XAMPP simentaneously.

abduraooft
12-11-2007, 06:57 AM
There must be some way, but I'm not sure how to change the port of apache since I haven't done this before.
However there is a line in the httpd.conf (in apache/conf) Listen 80. You may get some tutorials from the net on this.
PS: Don't forget to backup httpd.conf file !

saeed
12-11-2007, 08:20 AM
thanks for your help man.

appreciated !



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum