...

View Full Version : PHP - Unable to Load Dynamic Library. - Extension Problem (FFMPEG-PHP)



mhauth
11-13-2007, 03:58 AM
Hey everyone,

I am in the very last step of setting up my server with ffmpeg. I am attempting to install ffmpeg-php.

Here are the instructions I am to follow for the final step:
From http://forums.theplanet.com/index.php?showtopic=64541

FMPEG-PHP:

cd /usr/local/src/ffmpeg-php-0.5.0/

phpize

./configure

make

make install

NOTICE: Make sure this is the correct php.ini for the box!!


echo 'extension=/usr/local/lib/php/extensions/no-debug-non-zts-20020429/ffmpeg.so' >> /usr/local/Zend/etc/php.ini


NOTICE: Make sure this is the correct php.ini for the box!!

my ffmpeg.so is located at "'extension=/usr/lib/php/modules/ffmpeg.so"
I know my php.ini is located at "/etc/php.ini"

My SSH Shell readout is

[root@matts-server ffmpeg-php-0.5.1]# echo 'extension=/usr/lib/php/modules/ffmpeg.so' >> /etc/php.ini
[root@matts-server ffmpeg-php-0.5.1]# php -r 'phpinfo();' | grep ffmpeg
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules//usr/local/lib/php/extensions/' - /usr/lib/php/modules//usr/local/lib/php/extensions/: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules///usr/lib/php/modules/ffmpeg.so' - /usr/lib/php/modules///usr/lib/php/modules/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules//usr/lib/php/modules/ffmpeg.so' - /usr/lib/php/modules//usr/lib/php/modules/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules//usr/lib/php/modules/ffmpeg.so' - /usr/lib/php/modules//usr/lib/php/modules/ffmpeg.so: cannot open shared object file: No such file or directory in Unknown on line 0
PWD => /usr/local/src/ffmpeg-php-0.5.1
OLDPWD => /usr/local/src/ffmpeg-php-0.5.1
_SERVER["PWD"] => /usr/local/src/ffmpeg-php-0.5.1
_SERVER["OLDPWD"] => /usr/local/src/ffmpeg-php-0.5.1
_ENV["PWD"] => /usr/local/src/ffmpeg-php-0.5.1
_ENV["OLDPWD"] => /usr/local/src/ffmpeg-php-0.5.1


The Output Should Look like this

ffmpeg
ffmpeg support (ffmpeg-php) => enabled
ffmpeg-php version => 0.5.0
ffmpeg.allow_persistent => 0 => 0

If you could help me out I would really appreciate it. Have a good one.

Matt

Inigoesdr
11-13-2007, 04:54 AM
Manually edit your php.ini to set the correct path. While you're in there, make sure all of the settings are still there.. the ">>" operator in the *nix shell causes the output of the previous command to be written to the filename given after it, and I don't think it appends(could be wrong).



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum