...

View Full Version : mozilla and iframes



Decoy
01-04-2003, 05:55 AM
im having some trouble getting iframes to display on mozilla but they appear fine on internet explorer. can anyone tell me how to make them compatible with mozilla too? heres a small bit of source, its simple html

<tr>
<td colspan="5" height="409">
<div align="center"><iframe src="start.html" name="theiframe" scrolling=auto width=100% height=100% frameborder=0>Your
browser does not support iframes.</iframe></div>
</td>
</tr>

Davros
01-04-2003, 11:26 AM
I have mozilla 0.9.9.

Try this http://www.hyperdark.org/davros/unreal

If that works [does for me] then all iframes should work.

Here's my code:

<iframe src="home.html" name="a" width="100%" height="100%" marginwidth="0" marginheight="0" frameborder="0"></iframe>

Nightfire
01-04-2003, 11:28 AM
Older versions used ilayers.

Davros
01-04-2003, 11:33 AM
meaning i am using i layers?
I could try it with 1.0.
I did try it with 1.0
It still works.

jkd
01-04-2003, 07:38 PM
Originally posted by Nightfire
Older versions used ilayers.

No. Netscape 4 used ilayers, not the Mozilla project. Don't confuse Mozilla with Netscape - NS6 and NS7 are based on Mozilla 0.94 and Mozilla 1.0.1 respectively, but they are not the same.

Decoy
01-06-2003, 04:36 AM
thanks guys, i figured out what it was. i took out the div part surrounding the iframe script and it worked in mozilla. The iframe is the wrong height in mozilla but at least it works for those browsers now.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum