...

View Full Version : IE6 compatibility



onepowered
09-13-2007, 06:10 PM
Hi guys, I can't seem to figure out why IE6 won't render my page properly... I'm using margins and not padding - pretty sure I don't need the box model hack on any of my divs??

btw renders fine for me in ie7,ff,safari

any help much appreciated! Thanks so much guys!!

Here's the link (http://blogs.preps.ca)

Posted all the css here


body {
margin: 0 ;
background: #FAFAFA url(http://i.preps.ca/global/BG-body.png) repeat-x ;
font-family: "Lucida Sans Unicode", "Lucida Sans", Arial, Tahoma, Verdana, sans-serif ;
font-size: 11px ;
}

a {
color: #EEE ;
text-decoration: none ;
}
a:hover {
color: #DDD ;
}
#GLOBAL_CONTAINER {
margin: 0 auto ;
width: 960px ;
}
#SITE_WIDE_HEADER {
margin: 0 auto ;
padding: 0 ;
width: 960px ;
height: 139px ;
color: #FFF ;
background: transparent url(http://i.preps.ca/global/BG-SITE_WIDE_HEADER.png) no-repeat ;
}
#LOGO_CLICK_AREA {
float: left ;
width: 300px ;
height: 100px ;
}
#GLOBAL_SEARCH_CONTAINER {
float: right ;
width: 660px ;
height: 100px ;
}
#SITE_WIDE_NAVIGATION {
padding: 0 ;
padding-top: 100px ;
font-size: 12px ;
color: #FFF ;
margin: 0 ;
}
#SITE_WIDE_NAVIGATION a, #SITE_WIDE_HEADER a {
color: #FFF ;
}
#SITE_WIDE_NAVIGATION ul, #SITE_WIDE_HEADER ul {
margin: 0 ;
padding: 0 ;
list-style: none ;
padding-top: 11px ;
}
#SITE_WIDE_NAVIGATION li, #SITE_WIDE_HEADER li {
display: inline ;
padding-left: 33px ;
}
#CONTENT_CONTAINER {
float: left ;
margin: 0 auto ;
margin-left: 11px ;
width: 938px ;
background: #FFF url(http://i.preps.ca/global/BG-CONTENT_CONTAINER.gif) repeat-y ;
}
#AD_ID {
margin: 0 auto ;
background: transparent url(http://i.preps.ca/global/AD_ID.gif) no-repeat ;
width: 120px ;
height: 10px ;
font-size: 1px ;
}
#CONTENT_FOOTER {
clear: both ;
margin: 0 auto ;
width: 930px ;
height: 5px ;
background: transparent url(http://i.preps.ca/global/BG-CONTENT_FOOTER.gif) repeat-x ;
font-size: 1px ;
}
#LEFT_FOOTER {
clear: both ;
float: left ;
margin-top: 10px ;
width: 100px ;
}
#GLOBAL_FOOTER {
float: left ;
margin-top: 10px ;
width: 738px ;
text-align: center ;
font-size: 10px ;
color: #666 ;
}
#GLOBAL_FOOTER a {
color: #666 ;
}
#GLOBAL_FOOTER a:hover {
color: #333 ;
}
#POWERED_BY_PiPE8 {
float: left ;
margin-top: 10px ;
background: transparent url(http://i.preps.ca/global/BG-POWERED_BY_PiPE8.png) no-repeat ;
width: 100px ;
height: 20px ;
}

p {
text-align: left ;
margin: 0 ;
}

#CONTENT_LEFT {
float: left ;
width: 598px ;
background-color: #FEFEFE ;
margin: 10px 5px 10px 15px ;
}
#CONTENT_RIGHT {
float: right ;
width: 300px ;
margin: 10px 15px 10px 5px ;
}

#BIG_BOX {
background: transparent url(http://i.preps.ca/global/300x250.gif) no-repeat ;
width: 300px ;
height: 250px ;
}

#WIDE_BANNER {
margin: -1px auto ;
background: transparent url(http://i.preps.ca/global/BG-WIDE_BANNER.png) ;
width: 928px ;
height: 50px ;
}

PremiumBlend
09-13-2007, 06:17 PM
You are using padding for some inline styles and I see some inline styles like this:


<P class=MsoNormal style="MARGIN: 0cm 0cm 0pt">

Which should probably just replace by something like:


<P class="MsoNormal" style="MARGIN: 0;">

Those are just some quick observations, see if changing those around will help.

onepowered
09-13-2007, 07:48 PM
thanks, removed those ugly tags in the database -- things are still shifting to the right in ie6 only though

any other ideas??

http://preps.ca/blogs_ie6.jpg



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum