...

View Full Version : Text is "squished" in FF but no other browsers.



wyrd33
08-07-2007, 07:07 AM
At first I thought the font size was different in the different browsers, despite specifying 14px. After some looking and analyzing, I finally realized that FF is simply squishing the text together. Is there any way to fix that? All other browsers look fairly close in terms of text, but FF is way off.

http://www.danpeverill.com/portfolio/csshover/index.html

TIA.

Arbitrator
08-07-2007, 07:27 AM
http://www.danpeverill.com/portfolio...ver/index.htmlDo you have a link that actually works?

wyrd33
08-07-2007, 07:32 AM
Sorry about that. Fixed.

Jutlander
08-07-2007, 07:37 AM
I'm guessing that you use IE 7, because it looks broken in IE 6. IE 7 has a "feature" called cleartype, that will blur out the text a bit. Is this what you're refering to?

wyrd33
08-07-2007, 07:44 AM
No. I've tested it in FF, Safari, Opera, and IE7. In all browsers, the font (individual letters) are wider than they are in FF. At least that's how it's appearing to me. This is causing the text to take up more space in terms of width.

At least that's how it's appearing to me. Are you not seeing any text difference in terms of width between FF and the other browsers?

I haven't gotten around to testing it in IE6 yet.

garydarling
08-07-2007, 08:12 AM
No. I've tested it in FF, Safari, Opera, and IE7. In all browsers, the font (individual letters) are wider than they are in FF. At least that's how it's appearing to me. This is causing the text to take up more space in terms of width.

When I view your page in FF, the text is sans serif and flows to a second line. My default page text is 14px Verdana, but I checked the box that allows page styles to override my choice. By my reckoning, I should be seeing Georgia font instead of Verdana, but I don't.

In IE7 your text all appears on one line, and in the Georgia (or another serif) font.

Is it possible FF is overriding your page font with your browser settings?

wyrd33
08-07-2007, 08:32 AM
When I view your page in FF, the text is sans serif and flows to a second line. My default page text is 14px Verdana, but I checked the box that allows page styles to override my choice. By my reckoning, I should be seeing Georgia font instead of Verdana, but I don't.

In IE7 your text all appears on one line, and in the Georgia (or another serif) font.

Is it possible FF is overriding your page font with your browser settings?

It appears that FF is indeed using my default font rather than using what the stylesheet specifies. Is this a known FF bug or is there something I can do?

Arbitrator
08-07-2007, 08:44 AM
html, body, div, span, applet, object, iframe,
h1, h2, h3, h4, h5, h6, p, blockquote, pre,
a, abbr, acronym, address, big, cite, code,
del, dfn, em, font, img, ins, kbd, q, s, samp,
small, strike, strong, sub, sup, tt, var,
dl, dt, dd, ol, ul, li,
fieldset, form, label, legend,
table, caption, tbody, tfoot, thead, tr, th, td
{
margin: 0;
padding: 0;
border: 0;
outline: 0;
font-size: 100%;
font-weight: normal;
word-spacing: normal;
letter-spacing: normal;
text-transform: none;
font-family: normal;
vertical-align: baseline;
}


body
{
font-family: Georgia, "Minion Web", Palatino, "Book Antiqua", Utopia, "Times New Roman", serif;
}The first rule sets the font to a font named “normal”. This rule has greater specificity than the second rule and, thus, overrides it. As a result, if the user does not have a font named “normal” installed on their system, the browser’s default font is used.

wyrd33
08-07-2007, 09:39 AM
Yeah that was the problem. Thanks.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum