...

View Full Version : IE6 problems with css



rob coles
08-01-2007, 10:15 AM
Please see http://www.gral.com.au/
I have a problem with rollover buttons working correctly in IE6
As you rollover buttons below header they are meant to be all puple but there is a line of gray at the top!

Any idea on how to fix so it works in IE6.
No problem with opera, firefox, safari, netscape

Here is css for mid nav band:

#mid-nav { font-size: 90%; background-color: #a1a6a6; margin: 0; padding: 0 0 0 9px; }
#mid-nav ul { background-color: #a1a6a6; width: auto; height: 17px; overflow: hidden; margin: 0; padding: 0; list-style-type: none; }
#mid-nav li { text-align: center; height: auto; overflow: hidden; float: left; margin: 0; padding: 0.3em 0 0; text-align: center; width: 129px; height: 17px; overflow: hidden; border-right: 1px solid #fff; display: block; }
#mid-nav li.contact { text-align: center; height: auto; overflow: hidden; float: left; margin: 0; padding: 0.3em 0 0; text-align: center; width: 113px; height: 17px; overflow: hidden; border-right-width: 0; display: block; }
#mid-nav li.contactcurrent { background-color: #531980; text-align: center; height: auto; overflow: hidden; float: left; margin: 0; text-align: center; width: 113px; height: 17px; overflow: hidden; border-right-width: 0; display: block; }

#mid-nav a { color: #fff; text-decoration: none; display: block;}
#mid-nav a:visited { color: #e3e2e2; text-decoration: none; }
#mid-nav li:hover { background-color: #531980; display: block; }
#mid-nav a:active, #mid-nav li a:hover { color: #fff; font-weight: 500; background-color: #531980; text-decoration: none; }
.current { color: #bebebe; font-weight: 400; background-color: #531980; background-position: 0 bottom; text-decoration: none; text-align: center; width: 129px; height: 17px; overflow: hidden; padding-top: 0.2em; border-right: 1px solid #fff; display: block; }

And html:

<!-- start mid-nav -->
<div id="mid-nav">
<ul>
<li class="current"><a>HOME</a></li>
<li><a href="who-are-we.html">WHO ARE WE</a></li>
<li><a href="what-we-do.html">WHAT WE DO</a></li>
<li><a href="services.html">OUR SERVICES</a></li>
<li class="contact"><a href="contact.html">CONTACT</a></li>
</ul>
</div>
<!-- end mid-nav -->

<!-- start pict-band -->
<div id="pict-band">
<img src="images/office.jpg" alt="" height="160" width="269" border="0" /><img src="images/mid-4.jpg" alt="" height="160" width="130" border="0" /></div>
<!-- pict-band -->

NB: (there is an indent on the left and contac button is narrower)

effpeetee
08-01-2007, 10:31 AM
I can see no difference between Firefox and IE7 on my PC.
Neither show a grey band, the buttons are all purple.

Frank

_Aerospace_Eng_
08-01-2007, 10:32 AM
I can see no difference between Firefox and IE7 on my PC.
Neither show a grey band, the buttons are all purple.

Frank
He said the problem was in IE6. :confused:

effpeetee
08-01-2007, 10:34 AM
Yes, I realised that, I just sent the info to help.

I do not have IE6 on my PC

Frank

Is it possible to get IE6 now?

ahallicks
08-01-2007, 10:38 AM
I don't see a problem on IE6 on my machine (running Mulitple IE) ???

_Aerospace_Eng_
08-01-2007, 10:45 AM
Yes, I realised that, I just sent the info to help.

I do not have IE6 on my PC

Frank

Is it possible to get IE6 now?
Yes you can get Multiple IE (http://tredosoft.com/Multiple_IE). Just be aware some javascript may not work.

effpeetee
08-01-2007, 11:01 AM
Unfortunately I use Vista. I have not been able to get Virtual PC 2007 to run on my PC. It never seems to find the virtual disk. Thanks for the info anyway. Is there perhaps an online facility to do this?

Frank



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum