...

View Full Version : Image links show in MSIE but not in Firefox



Character Q
07-16-2007, 07:33 PM
Here's the page (http://******). You can see the buttons "Play Runescape" in MSIE, but they don't appear on the page in Firefox. How do I fix this?


Here's how the button portion is arranged:



<html>
<head>

<style type="text/css">
#buttons {
width: 466px;
margin-bottom: 13px;
margin-left: 8px;
}
#button1 {
width: 200px;
height: 100px;
margin-left: 22px;
}
#button1 a {
width: 200px;
height: 100px;
background-image: url('buttonplay.gif');
background-repeat: no-repeat;
background-position: 0px 0px;
}
#button1 a:hover {
background-position: 0px -100px;
}
#button2 {
width: 200px;
height: 100px;
margin-left: 11px;
}
#button2 a {
width: 200px;
height: 100px;
background-image: url('buttonjoinfs.gif');
background-repeat: no-repeat;
background-position: 0px 0px;
}
</style>

</head>
<body>

<table id="buttons" cellpadding="0" cellspacing="0" border="0">
<tr>
<td style="width: 50%;">
<div id="button1"><a href="page.htm"></a></div>
</td>
<td style="width: 50%;">
<div id="button2"><a href="page.htm"></a></div>
</td>
</tr>
</table>

</body>
</html>

_Aerospace_Eng_
07-16-2007, 07:57 PM
You need to make the links display:block; in the CSS.

Character Q
07-16-2007, 08:06 PM
You need to make the links display:block; in the CSS.

Oh really? What's the default for display in Firefox?

It's working. Thanks plenty, Aerospace.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum