...

View Full Version : PHP is not working when using HTTPS



mesh2005
07-05-2007, 03:06 PM
When I request the pages http://localhost/info.php it works fine but when I use https://localhost/info.php I get a box to save or open the info.php! The server sends the php file without execution! I use Apache 2,PHP 4 and MySQL 4 on Linux Ubuntu 6.06
Thank you

eshban
07-05-2007, 03:19 PM
go to this site and install this package. it will install php, mysql and apache as well.

in this package there is an option to run localhost at https:


http://www.apachefriends.org/en/xampp-linux.html

thanks

TheShaner
07-05-2007, 04:03 PM
go to this site and install this package. it will install php, mysql and apache as well.

in this package there is an option to run localhost at https:


http://www.apachefriends.org/en/xampp-linux.html

thanks
Whoa! DO NOT DO THE ABOVE ADVICE if you do not want all your apache, php, and mysql configuration files and mysql data overwritten!!!

I haven't had to set up SSL on Apache just yet, but you should probably follow this guide:
http://www.linuxhelp.net/guides/apachessl/

This will help you set up your Apache server to run SSL, which is what you're attempting to do when you run https. You will need mod_ssl, which may or may not have come with your apache installation. You will have to check in your modules folder in apache. You will then have to modify your Apache configuration file to get it set up for SSL. Remember, you will need an SSL certificate to use SSL.

-Shane



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum