...

View Full Version : Google Ad Woes in IE 7



l Squid l
07-05-2007, 04:33 AM
Well, first my site. http://elementalstudios.freehostia.com/

The ads comes nicely out in Firefox, but in IE its on top of the Layout, I have been using CSS and HTML, I would like the ads to view like it is in Firefox, any help is appreciated.:thumbsup:

l Squid l
07-05-2007, 09:36 PM
Anyone?

CaptainB
07-05-2007, 09:40 PM
What do you mean? I have em' in the left hand side in the black space. Where should they be in FF?

l Squid l
07-06-2007, 12:30 AM
This is what I mean in Firefox it views as this. http://i97.photobucket.com/albums/l231/Squid267/FF.jpg

And in IE 7 it looks like this:
http://i97.photobucket.com/albums/l231/Squid267/IE7.jpg

CaptainB
07-06-2007, 11:40 AM
Why is your div set to align="right" ?


<div align="right" class="google"><script type="text/javascript"><!--
google_ad_client = "pub-2787745004181943";
google_ad_width = 120;
google_ad_height = 600;
google_ad_format = "120x600_as";
google_ad_type = "text_image";
//2007-07-04: Games
google_ad_channel = "1177802074";
google_color_border = "000000";
google_color_bg = "000000";
google_color_link = "CC0000";
google_color_text = "000000";
google_color_url = "CC0000";
//-->
</script>
<script type="text/javascript"
src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</div>

Try to change it to align="left".

l Squid l
07-27-2007, 04:42 AM
Bump, I didn't reply because my google ads account got banned. But I got it back so Im still having the same problem IE...

Jutlander
07-27-2007, 11:33 AM
I'd suggest to remove that align attribute completely as it is deprecated.

l Squid l
07-27-2007, 03:23 PM
Ok, I have removed it. Hmm still there.

ahallicks
07-27-2007, 03:30 PM
If you want it in the top left as it is in Firefox then the problem is probably because IE does not recognise position: fixed; in anything other than the HTML. Try absolutely positioning it in the top left and seeing how that comes out. Put is first thing after the <body> too.

l Squid l
07-27-2007, 05:13 PM
What do you mean by "Put is first thing after the <body> too."

ahallicks
07-27-2007, 05:30 PM
*Call the script first thing after the body. I had a look at your code and noticed that you just use a script in the head, whereas I put the adds at the bottom of my sites so put the code at the bottom for the ads.

Try putting it just after the opening body tag.

l Squid l
07-27-2007, 05:39 PM
Ok....Lets see.. still nothin..I wish there no need for cross broswer, like a some unfied thing..i dont know...

Jutlander
07-27-2007, 05:46 PM
Squid, try and remove the position fixed declaration in your google class and set the float value to left instead of right.

ahallicks
07-27-2007, 05:53 PM
Squid, try and remove the position fixed declaration in your google class and set the float value to left instead of right.

Yeah, that's what I meant to say!

l Squid l
07-27-2007, 07:02 PM
It was always "left" I believe. Well, I removed the Position:Absolute..Still Its in the same position. What do you think is causing this, I try changing the float to right if that helps it didn't even budge, so I think its trying tell me something..Idk.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum