...

View Full Version : Website Gone Wrong



scp5
06-03-2007, 02:38 PM
Hey,
I downloaded a template of a website but it wont work in internet explorer, it works fine on my mac with safari and firefox.

www.stuarts-photos.com/scp/

Any help would be great

Stuart

rmedek
06-03-2007, 04:25 PM
Welcome to CF. In the future, please read our Rules (http://codingforums.com/rules.htm) and Posting Guidelines (http://codingforums.com/postguide.htm) before posting. Specifically, use a more descriptive title when posting a new thread. Vague teaser titles like "Website Gone Wrong" are frowned upon.

Thanks.

koyama
06-03-2007, 05:00 PM
I downloaded a template of a website but it wont work in internet explorer, it works fine on my mac with safari and firefox.
The template that you downloaded is poorly made. That, together with IE's rendering bugs, is why nothing shows up in this browser.

In IE, a child block-level element will incorrectly be positioned according to the text-align property.

If I were you, I would search for a better template or try to code myself.

For now, you can use these fixes:

Replace this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
with this:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
Change your CSS to this:


body
{
background: rgb(211, 226, 195);
height: 99%;
margin: 0;
padding: 0;
line-height: 150%;
/* text-align: center; */
}
*
{
font-size: 8pt;
font-family: Tahoma, Verdana, sans-serif;
color: #000000;
/* text-align: right; */
}
#first_container
{
margin: 0 auto 0 auto;
/* display: table; */
height: 100%;
position: relative;
overflow: hidden;
/* width: 660px; */
width: 1514px;
}

scp5
06-03-2007, 08:44 PM
sorry about that RMEDEK and thanks KOYAMA it works now :)

thanks for your help

www.stuarts-photos.com



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum