...

View Full Version : Trouble embedding Windows Media Player in MySpace blog posts



keystroke
03-09-2007, 12:46 AM
Hey,

For a few weeks now I haven't been able to embed songs on my MySpace blog. I was able to do it before, but now the code gets deleted each time I try to embed.

If anyone can shed some light on the subject, it would be much appreciated. If you need more information, just ask.

Here are the codes I've tried:


<embed src="mysongurl" width="300" height="100" type="audio/mpeg mpga mp2 mp3" autostart="false" loop="false">


<EMBED SRC="mysong" AUTOSTART="true" LOOP="false" HIDDEN="false" Width="145" Height="30">


<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Kristina's Music</title>
<style type="text/css">
body {
text-align:center;
}
</style>
<script type="text/javascript">
function PlayIt(what){
player.document.getElementById('music').innerHTML='<object width="300" height="100" '
+'classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6" '
+'codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701" '
+'standby="Loading Microsoft Windows Media Player components..." type="application/x-oleobject">'
+'<param name="url" value="'+what+'">'
+'<param name="uiMode" value="full">'
+'<param name="autoStart" value="true">'
+'<param name="loop" value="true">'
+'<embed type="application/x-mplayer2" '
+'pluginspage="http://microsoft.com/windows/mediaplayer/en/download/" '
+'showcontrols="true" uimode="full" width="300" height="45" '
+'src="'+what+'" autostart="true" loop="true">'
+'</object>';
}
</script>
</head>

<body>
<select name="player" onchange="PlayIt(this.value)">
<option value="none">::Choose Song::</option>
<option value="mysong url ">My song Title</option>
</select><br>
<div id="music">
<object width="300" height="100"
classid="CLSID:6BF52A52-394A-11d3-B153-00C04F79FAA6"
codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=5,1,52,701"
standby="Loading Microsoft Windows Media Player components..." type="application/x-oleobject">
<param name="url" value="">
<param name="uiMode" value="full">
<param name="autoStart" value="true">
<param name="loop" value="true">
<embed type="application/x-mplayer2"
pluginspage="http://microsoft.com/windows/mediaplayer/en/download/"
showcontrols="true" uimode="full" width="300" height="45"
src="" autostart="true" loop="true">
</object>
</div>
</html>

_Aerospace_Eng_
03-09-2007, 06:02 AM
You can't use javascript on myspace. You can't use the object tag either. Try this

<embed type="application/x-mplayer2"
pluginspage="http://microsoft.com/windows/mediaplayer/en/download/"
showcontrols="true" uimode="full" width="300" height="45"
src="mysongurl" autostart="1" playcount="9999">

keystroke
03-09-2007, 05:34 PM
Okay, I will try that. But, how does that explain the other two codes I tried? I didn't think that this:
<EMBED SRC="mysong" AUTOSTART="true" LOOP="false" HIDDEN="false" Width="145" Height="30"> was JavaScript.

Thanks.

_Aerospace_Eng_
03-09-2007, 05:41 PM
I think the player has to be visible. I don't do myspace very much. Just live with the fact that they don't allow certain things.

phils_a_ginger_
04-01-2007, 05:11 PM
<embed type="application/x-mplayer2"
pluginspage="http://microsoft.com/windows/mediaplayer/en/download/"
showcontrols="true" uimode="full" width="300" height="45"
src="mysongurl" autostart="1" playcount="9999">


how do i make this so i can have more than one song one?please.

zoobie
04-04-2007, 09:41 AM
phils...you need to start your own thread

ArcticFox
04-04-2007, 09:09 PM
MySpace does not like the EMBED tag. You'll have to do it with OBJECT tags only.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum