...

View Full Version : any idea why just on this page the footer is moved over?



mhunt
02-27-2007, 03:29 AM
http://mh-interactive.com/auth/auth-login.php
on that page the footer moves to the right like 5px and i cant figure out why
here is my css:



body {
margin: 0 auto;
padding: 0;
font-family: Arial, Verdana, Sans-Serif;
font-size: 0.8em;
background: #E7E7E7 url("../../images/main_bg.jpg") no-repeat;
}
* { margin: 0; padding: 0; }
a {
text-decoration: none;
color: #B60400;
}
a:hover { color: #808080; }

a img { border: 0; }

h3 {
font-size: 1.3em;
margin: 0 0 5px 0;
padding: 2px 0px 0px 0px;
border-bottom: 2px solid #eee;
color: #B60400;
}
form {
margin: 0;
padding: 0;
}
div.infoBox {
margin-left:auto;
margin-right:auto;
text-align:center;
width: 50%;
border-width: 1px;
border-style: solid;
border-color: #858585;
padding: 4px;

}
input.submitButton {
text-align:center;
background-color: #fff;
color: black;
border-width: 1px;
border-color: black;
border-style: solid;
border-right-width: 2px;
border-bottom-width: 2px;
}
.blue { color: #286ea0; }
.red { color:#B60400; }

#pageContainer {
width: 760px;
margin: 0 auto;
height: 580px;
padding: 6px 10px 0px 10px;
background: url("../../images/bg.gif") no-repeat;
}

#main {
padding: 9px 4px 0 2px;
color: #303030;
width: 736px;

}

#content {
clear: both;
text-align: right;
padding: 20px 15px 0 0;
margin: 0px 0 3px 0;
height: 40px;
border-bottom: 2px solid #eee;
background: #FFF url("../../images/fade.gif") repeat-x;
color: #808080;
}

#title {
float: left;
font-size: 14pt;
font-weight: bold;
padding: 0 0 0 10px;
}

#navigation {
/*clear: left;*/
float: left;
width: 150px;
margin: 0 0 10px 0;
padding: 0;
font-size: 0.9em;
}

#navigation ul {
list-style: none;
width: 150px;
margin: 0 0 3px 0;
padding: 0;
font-size: 1.1em;
border-right: 2px solid #ccc;
}

#navigation li {
margin-bottom: 4px;
padding: 0 1px 0 10px;
}
#navigation li a {
font-size: 9pt;
font-weight: bold;
text-align: right;
height: 20px;
text-decoration: none;
color: #B60400;
display: block;
padding: 6px 10px 0 10px;
background: #fff;
border-bottom: 1px solid #ccc;
}

#navigation li a:hover {
color: #000;
background: #eeeeee;
border-bottom: 1px solid #ccc;
}
.recentArticles {
/*float: right;*/
float:left;
width: 225px;
margin: 0 0 10px 0;
padding: 5px 13px 20px 10px;
border-left: 1px solid #DDD;
color: #B60400;
line-height: 1.5em;
height: 385px;
}

.recentArticles p {
margin: 0px;
font-size: 90%;
}

.recentArticles a {
display: block;
padding-bottom: 4px;
margin-bottom: 2px;
border-bottom: 1px dotted #ccc;
}
.mainBody {
/*margin: 0 300px 0 150px;*/
margin: 0;
float: left;
padding: 5px 10px 5px 10px;
line-height: 1.6em;
text-align: left;
color: #5D5D5D;
border-left: 2px solid #eee;
width: 300px;
min-height: 300px;
}

.mainBody a, #mainBody a:visited {
text-decoration: underline;
color: #B60400;
}

.mainBody p {
padding: 0;
margin: 0;
}

#footer {
clear: both;
color: #808080;
background: #FFF;
font-size: 0.8em;
text-align: center;
padding: 9px 0 9px 0;
margin: 10px 0 10px -1px;
border: 1px solid #ccc;
width: 741px;
}

#footer a {
text-decoration: underline;
color: #B60400;
}

#footer a:hover {
color: #000;
}
ul#adminList {
font: bold 11px verdana, arial, sans-serif;
list-style-type: none;
padding-bottom: 24px;
border-bottom: 1px solid #ccc;
margin: 0;
width: 550px;
}

ul#adminList li {
float: left;
height: 21px;
background-color: #fff;
margin: 2px 2px 0 2px;
border: 1px solid #ccc;
}

li#active a { color: #000; }

#adminList a {
float: left;
display: block;
color: #666;
text-decoration: none;
padding: 4px;
}

#adminList a:hover { background: #ccc; }

.loginBtn {
background-color: #eeeeee;
border: 1px solid #000;
}

harbingerOTV
02-27-2007, 04:08 AM
im getting these warnings:

line 30 column 1 - Warning: missing </table> before </body>
line 29 column 1 - Warning: missing </div>
line 11 column 3 - Warning: missing </div>
line 10 column 2 - Warning: missing </div>
line 30 column 1 - Warning: trimming empty <table>


counting the divs, your missig one of the closing divs.



<td><input type="password" name="password" /> </td>

</tr>
<td>
<td><input type="submit" value="Login" class="submitButton"></td>
<td>&nbsp;</td>
</tr>
</form>


it also looks like your not closing that last tr.

fix all those up first. one might be the cilprit

mhunt
02-27-2007, 01:20 PM
got it thanks



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum