...

View Full Version : Secondary Nav IE7 Great; FireFox Bad



prophetofjah
02-07-2007, 08:11 PM
Hello,
I am having trouble figuring out why IE7 and Firefox are displaying the following page differently: http://www.fathomseo.com/fathomwebsiteredesign/SERVice_plan.asp

When viewed in IE7, in the navigation on the left had side, the link "SERV Process" is indented and has a graphic arrow on the left hand side.

When viewed in Firefox, "SERV Process" does not get indented, nor does it have the arrow.

The rest of my nav works fine, its just that level of the nav that has the problem in Firefox with displaying the current page.

Could someone please identify the issue with firefox and suggest a solution?

Thanks sooooooo much,
PoJ

_Aerospace_Eng_
02-07-2007, 08:28 PM
Hmm validating your html might reveal what the problem could be. See your validation results here (http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.fathomseo.com%2Ffathomwebsiteredesign%2FSERVice_plan.asp).

You can't use the same ID more than once.

prophetofjah
02-08-2007, 11:09 PM
Hello,
After validating my code, I fixed my id tags so that they are unique. However, the issue is still occurring and only with that one level of my nav. The code works fine for the nav level bellow and the one above.

Any other ideas?

Thanks,
PoJ

prophetofjah
02-08-2007, 11:55 PM
Howdy,

I found out what was wrong:

#350manufactb #350manufact

I guess ID tags cant start with numbers. It screwed up all the other id tags I had in the same category!

Thanks!,
PoJ

felgall
02-09-2007, 02:38 AM
ids MUST start with a letter or underscore and can only contain letters, numbers and underscores.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum