...

View Full Version : Disappearing Divs (when viewed in IE)



drippin
02-03-2007, 10:00 PM
Hey everyone, i was wondering if you guys could help me as i've looked through and through the code to try and find the problem but i cant seem to find it.

When viewing my profile in firefox the whole page looks how it should, however when i or my mates view the website using Internet Explorer my div's disappear... I've tried a few things to try and get them to display such as visibility:visible or even z-index but nothign seems to be forcing these div's into viewable states.

The URL to my profile is: www.profileheaven.com/drippin

And the div's that aren't displaying are ID vidbox and vidbox2. Any ideas or suggestions will be greatly appreciated! Thanks for any help you guys might be able to give me.

John

drippin
02-03-2007, 10:38 PM
Here's my code anyway, just incase...



<style>
body {
background-color:#000000;
background-image:url(http://img240.imageshack.us/img240/8935/bgnb8.jpg);
background-repeat:repeat-y;
background-position:50% 0;
}

.hugewin .headtext, .fullwin .headtext {
background-color:#eeeeee;
border-bottom:1px dashed #dddddd;
}

#usertext .btn2 { display:none; }

#main {
background-image:url('http://img250.imageshack.us/img250/5729/mainbw5.jpg');
background-color:#000000;
height:500px;
}

a,a:link,a:visited,a:active { color:#333333; font-weight:bold; }
a:hover { color:#999999; }

#header,#nav { display:none;}

#usertext .headtext, #usertext .footer { display:none; }
#usertext{position:absolute;top:220px; left:52px; width:192px; background-color:#000000;border-width:0;}

#comments { position:absolute; top:245px; left:300px; width:410px; border-width:0; background-color:transparent; }
#comments { height:292px; overflow:hidden; padding:0; }
#comments .headtext { display:none; }
#comments .body { height:80px; overflow:visible; text-align:left; }
#comments td { vertical-align:top; }

#mylink1,#mylink1:link,#mylink1:visited,#mylink1:active {
background-image:url(http://img240.imageshack.us/img240/1205/messagekb9.jpg);
background-repeat:no-repeat; background-position:top left;
width:200px; height:15px; display:block; text-decoration:none;
}

#mylink1:hover { background-position:0 -15px; }

#mylink2,#mylink2:link,#mylink2:visited,#mylink2:active {
background-image:url(http://img252.imageshack.us/img252/8435/picsgy8.jpg);
background-repeat:no-repeat; background-position:top left;
width:180px; height:15px; display:block; text-decoration:none;
}

#mylink2:hover { background-position:0 -15px; }

#F,#mylink3:link,#mylink3:visited,#mylink3:active {
background-image:url(http://img484.imageshack.us/img484/9699/frienduq7.jpg);
background-repeat:no-repeat; background-position:top left;
width:200px; height:15px; display:block; text-decoration:none;
}

#mylink3:hover { background-position:0 -15px; }

#mylink4,#mylink4:link,#mylink4:visited,#mylink4:active {
background-image:url(http://img264.imageshack.us/img264/5540/guestyw2.jpg);
background-repeat:no-repeat; background-position:top left;
width:200px; height:13px; display:block; text-decoration:none;
}

#mylink4:hover { background-position:0 -15px; }

#mylink5,#mylink5:link,#mylink5:visited,#mylink5:active {
background-image:url(http://img240.imageshack.us/img240/5864/friendsbw9.jpg);
background-repeat:no-repeat; background-position:top left;
width:200px; height:15px; display:block; text-decoration:none;
}

#mylink5:hover { background-position:0 -15px; }

#usertext .btn2 { display:none; }

#vidbox { position:absolute; width:200px; height:150px; left:460px; top:-170px; background-color:#000000; visibility:visible; z-index: 1;}

#vidbox2 { position:absolute; width:200px; height:150px; left:20; top:120px; background-color:#000000; visibility:visible; display:block; z-index: 1;}

#footer { background-color:#000000; }
</style>

and here is what i've included into the HTML body...



<a href="/myMail.php?do=compose&amp;clientName=drippin" id="mylink1">&nbsp; </a><a href="../photogallery.php?clientID=72832" id="mylink2">&nbsp; </a><a href="../myFriends.php?do=newFriend&amp;friendID=72832&amp;return=yes" id="mylink3">&nbsp; </a><a href="../guestbook.php?clientID=72832" id="mylink4">&nbsp; </a><a href="../friends.php?clientID=72832" id="mylink5">&nbsp;</a>
<div id="vidbox"><embed width="200" height="150" name="MySpaceVideoCode" pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/Products/MediaPlayer/" src="http://www.videocodezone.com/videos/l/ludacris/money_maker_856782.asx" type="application/x-mplayer2" showcontrols="0" showstatusbar="0" loop="true" enablecontextmenu="0" displaysize="0"></embed></div>
<div id="vidbox2"><img width="160" alt="" src="http://media.profileheaven.com/images/profileImages/73/72832/3718182.jpg" /><br />
<img width="24" alt="" src="http://media.profileheaven.com/images/profileImages/73/72832/3714560.jpg" /><a href="http://www.myspace.com/hitcounters"><img border="0" src="http://www.mortgagemeter.net/profileheaven-v2-My_Space_Counters.jpg" alt="My Space Counters" /></a><img width="45" alt="" src="http://media.profileheaven.com/images/profileImages/73/72832/3718165.jpg" /><br />
<img width="156" height="60" alt="" src="http://media.profileheaven.com/images/profileImages/73/72832/3718194.jpg" /></div>

drippin
02-04-2007, 03:59 AM
No suggestions? =(

_Aerospace_Eng_
02-04-2007, 07:39 AM
It was only about 5-6 hours. You arent the only one that needs help. Try adding position:relative; to the css for the divs that are showing up.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum