...

View Full Version : Background Field wont fill useing IE



turtleman
02-02-2007, 01:32 PM
I think I almost have this taken care of in Firefox but viewing it in IE theres still aways to go... What I'd like to get help with is CSS adjustments for my Skins/rsi/StyleSheets/popup.css ,, If you click Here (http://www.rsigrowers.com/cactus/ariocarpus-/ariocarpu-retusus/prod_82.html) then click "More Images" (right under the product image) in Firefox its how I want it,, but in IE the background color dosent expand in the field

Where in my CSS am I off? or what do I need to add to the CSS to help IE out?

What I'm trying to accomplish is for customers to be able to view a Full Sized Image that I'd rather FTP to the Images folder instead of useing the carts upload feature, (which seems to resize my images), If anyone views the other products, those images were uploaded via the carts upload feature, (hence "resized")
#pageSurround is were the color is for the background


body {
margin: 5px;
background-color: #A5A5A5;
background-attachment: scroll;
background-image: url(../styleImages/backgrounds/pageBg.jpg);
background-repeat: repeat-x;
background-position: top;
}
#pageSurround {
background-color: #F2dec6;
border: 2px solid #000000;
margin-bottom: 5px;
}
#divThumbsImg {
overflow:auto;
height: 700px;
width: 120px;
text-align: center;
float: left;
margin-right: 5px;
border-right: 2px solid #a44904;
}
.thumbsImg {
border: 1px solid #000000;
background-color: #000000;
}
#divMainImg {
float: left;
width: 600px;
height: 600px;
text-align: center;
overflow: hidden;
margin-bottom: 5px;
}
a.popupLink {
font-family: Arial, Helvetica, sans-serif;
font-size: 75%;
text-decoration: none;
color: #000000;
font-weight: bold;
}
a.popupLink:hover {
color: #070F72;
font-weight: bold;
}
.txtCopyright, a.txtCopyright {
text-align: left;
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 1px;
padding-top: 5px;
color: #999999;
}
a.txtCopyright:hover {
text-decoration: none;
}


Any help is always apperciated :)

koyama
02-02-2007, 11:52 PM
You need to clear your float. Because of IE, clearing a float (http://css-discuss.incutio.com/?page=ClearingSpace) has become a science in itself. You may try this:


#pageSurround {
background-color: #F2dec6;
border: 2px solid red;
margin-bottom: 5px;
width: 100%;
overflow: auto;
}



This might not be so good anyway because of your border. Instead of the above, use another method:
Replace this:


<br clear="all">

with this


<div style="clear: both; font-size: 0; line-height: 0">&nbsp;</div>

turtleman
02-03-2007, 01:52 AM
width: 100%;
overflow: auto;

That did the trick koyama, seems fine to all my browsers now

I want to Thank You very much for taking the time to help me, I'm still on the learning curve with So Very Much of this

Your help's apperciated :thumbsup:



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum