...

View Full Version : server caching pages



esthera
12-26-2006, 03:05 PM
I am programming on a new web server.
Soemthing strange is happening -- the first time I uploaded the files there were some errors - I fixed but it is still showing me the old errors and won't show me anything new. (even if I put response.write "hello" I don't see it)

it is not my browser causing this -- it is only happening from that web server.

Any Ideas what could be causing this and what I can do to fix?

ess
12-26-2006, 04:46 PM
Hello there.

Sorry, but I am going to ask a stupid question. When you updated the files, did you upload them again to the server? If you have, then surely you have have been prompted to confirm that you wanted to override the existing files on the server. Make sure that you answer yes.

Also. You should clear all the browser cache.

Also. you should include meta information about when the page should expire. Here is an example.

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<meta http-equiv="CACHE-CONTROL" content="NO-CACHE" />
<meta http-equiv="PRAGMA" content="NO-CACHE" />
<meta name="GOOGLEBOT" content="NOARCHIVE" />
<meta http-equiv="EXPIRES" content="Mon, 26 Jul 1997 05:00:00 GMT" />
<title>Page Title here</title>
</head>
<body>
<%
// your asp code here.
%>
</body>
</html>

Good luck.
Ess

esthera
12-26-2006, 05:01 PM
yes i checked that and it's not the browser caching but the server as if I upload to another server they are ok

bostjank
12-31-2006, 03:40 PM
There are 2 setting in IIS that you can use to fine-tune caching policy on the server:

IIS > Web sites > Properties > Cache options (for ASP caching settings)
IIS > Web sites > Your Virtual Directory > Properties > HTTP Headers > Enable content expiration


Hope this helps.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum