...

View Full Version : Css does not show up at ALL in IE (works in ff)



diizy
12-19-2006, 11:32 PM
Hi guys, i have a website (pad.diizy.com) it uses only css for the layout (divs) and it does not, in ANY WAY show up AT ALL IN IE. can someone help. here is the html + external css:
(i did everything in firefox)
index.html

<html>
<head>
<title>Page A day project</title>
<link rel="stylesheet" type="text/css" href="style.css" media="screen, projection">

<script type="text/javascript">
<script src="http://www.google-analytics.com/urchin.js" type="text/javascript">





<body>

<center>

<h>Page-a-day project:<BR>
<div>
<b class="box">
<b class="box1"><b></b></b>
<b class="box2"><b></b></b>
<b class="box3"></b>
<b class="box4"></b>
<b class="box5"></b>
</b> <div class="box_content"><font color=white>
This project is about FUN thats right, i will be trying to make new pages on my website as often as possible. Maybe not on a true day to day scale, but regardless my goal here is to try to alteast make it consistent.
<BR><BR>
Pages:<BR>
<a href="/day1.html">The first</a>

</font>

</div>
<b class="box">
<b class="box5"></b>
<b class="box4"></b>
<b class="box3"></b>
<b class="box2"><b></b></b>
<b class="box1"><b></b></b>
</b>
</div>

</center>

</body>


</html>


style.css


a:link {
color: white;
}
a:visited {
color: white;
}
a:hover {
color: #CCCCCC;
background-color: #333333;
text-decoration: none;
}
a:active {
color: #333333;
}

body {
background-color: #B8B8B8;
font-family: helvetica;
font-variant:small-caps;
color: white;
}

h {
font-family: helvetica;
font-size:25pt;
font-variant:small-caps;
color: black;
}

.box{
width:500px;
display:block;
}
.box *{
display:block;
height:1px;
overflow:hidden;
background:#000000;
}
.box1{
border-right:1px solid #686868;
padding-right:1px;
margin-right:3px;
border-left:1px solid #686868;
padding-left:1px;
margin-left:3px;
background:#2e2e2e;
}
.box2{
border-right:1px solid #a5a5a5;
border-left:1px solid #a5a5a5;
padding:0px 1px;
background:#222222;
margin:0px 1px;
}
.box3{
border-right:1px solid #222222;
border-left:1px solid #222222;
margin:0px 1px;
}
.box4{
border-right:1px solid #686868;
border-left:1px solid #686868;
}
.box5{
border-right:1px solid #2e2e2e;
border-left:1px solid #2e2e2e;
}
.box_content{
width:500px;
padding:0px 0px;
background:#000000;
}

All the .box css stuff is for antialiased borders on the Div tables (not using images)


Any help would be appreciated! thanks in advance!!

Graft-Creative
12-19-2006, 11:38 PM
well you are missing a closing </ head> tag - that probably isn't helping much :)

Gary

diizy
12-19-2006, 11:42 PM
well you are missing a closing </ head> tag - that probably isn't helping much :)

Gary

wow! that was dumb!
well i have addeed that now, regardless, it still isnt showing.

Graft-Creative
12-19-2006, 11:45 PM
wow! that was dumb!
well i have addeed that now, regardless, it still isnt showing.
Nah, it's not dumb - I'm forever doing stuff like that :)

Try adding a proper Doctype then, if it still doesn't work, I think we can get forensic with it ;)

Gary

diizy
12-19-2006, 11:51 PM
Nah, it's not dumb - I'm forever doing stuff like that :)

Try adding a proper Doctype then, if it still doesn't work, I think we can get forensic with it ;)

Gary

alright, i have now added the proper doctype ( <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd"> ), yet, nothing shows. it would be great to understand moreso why this is happening too!

Graft-Creative
12-20-2006, 12:12 AM
ok, now try validating you file W3C html validator (http://validator.w3.org/)

..and your CSS:

CSS Validator (http://jigsaw.w3.org/css-validator/)

koyama
12-20-2006, 12:16 AM
hmm... you are missing closing </script> tags:)

diizy
12-20-2006, 12:30 AM
okay, after getting alot of validations (still not validating, but i will be getting that to work) i finally got it working in ie.

Thank you for all your help! I will hopefully be able to one day figure out why this is happening.

Graft-Creative
12-20-2006, 12:50 AM
Nice one Diizy - seriously, although it sounds a bit of a brush off, but: Doctype - then validate will always get you at least halfway toward soving your problem :)

Gary

codingmasta
12-20-2006, 03:54 PM
Lol I haven't such a website without the head tag...

codingmasta
12-20-2006, 05:35 PM
If you dont want any troubles, use mozila firefox or netscape.
CSS ***** in ie

whizard
12-20-2006, 05:43 PM
Lol I haven't such a website without the head tag...

It was a simple mistake, I've done it lots of times. Also, I noticed in another thread, you posted code without a <title> tag...


If you dont want any troubles, use mozila firefox or netscape. CSS ***** in ie

Too bad 95% of the world looks at websites in IE, so they have to be designed to appear correctly there.

These posts aren't really very relevant to the subject of the thread.
Dan

Graft-Creative
12-20-2006, 08:50 PM
okay, after getting alot of validations (still not validating, but i will be getting that to work) i finally got it working in ie.

Thank you for all your help! I will hopefully be able to one day figure out why this is happening.

What was the fix diizy?

Gary



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum