...

View Full Version : Upgrade to PHP 5.2 problem



directprint
11-24-2006, 10:36 PM
I have just upgraded my Mac OS server to PHP 5.2 and my vbulletin 3.6.4 forum now has this error...


Warning: require_once(./global.php) [function.require-once]: failed to open stream: No such file or directory in /Volumes/SOHOraid/forum/index.php on line 55

Fatal error: require_once() [function.require]: Failed opening required './global.php' (include_path='.:/usr/local/php5/lib/php') in /Volumes/SOHOraid/forum/index.php on line 55

I have been trying many place to solve this error including vbulletin website without success, hoping someone her might know something.

marek_mar
11-24-2006, 11:42 PM
It's not really a php5.2 error.
Make sure that the file: /Volumes/SOHOraid/forum/global.php exists.

directprint
11-25-2006, 01:03 AM
It's not really a php5.2 error.
Make sure that the file: /Volumes/SOHOraid/forum/global.php exists.
It actually does exist.

CFMaBiSmAd
11-25-2006, 01:35 AM
Either there is a permissions problem that is preventing PHP from being able to read the file (less likely) or the include_path syntax is not valid for your operating system (more likely.) Since I don't know anything about your operating system, I cannot advise you on the second possibility, but try changing the slashes - / to \ and the separator - : to ; I have also seen posts where a trailing slash is needed on the path setting.

Searching the Internet turns up many people and several live web sites experiencing the same problem.

Do you have access to your previous php.ini for comparison purposes?

directprint
11-25-2006, 03:05 AM
Either there is a permissions problem that is preventing PHP from being able to read the file (less likely) or the include_path syntax is not valid for your operating system (more likely.) Since I don't know anything about your operating system, I cannot advise you on the second possibility, but try changing the slashes - / to \ and the separator - : to ; I have also seen posts where a trailing slash is needed on the path setting.

Searching the Internet turns up many people and several live web sites experiencing the same problem.

Do you have access to your previous php.ini for comparison purposes?
Thanks I will give that a try, my previous PHP 4 php.ini file worked fine, but I have since removed it.

directprint
11-25-2006, 06:10 AM
No luck with changing the slashes.

firepages
11-25-2006, 05:38 PM
At the head of the script try (before the require)


<?php
ini_set('include_path',ini_get('include_path').':/Volumes/SOHOraid/forum');
?>

.. thats not the solution as such but if it works it might point us in the right direction.. I also doubt its a PHP5 issue rather something else on the server (apache or filesystem config)


PS `.:/` is valid for *nix \; is for win32



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum