View Full Version : connection to mysql table fails - basic

11-21-2006, 11:46 PM
hello all,

i want to create an upload for images for my personal website.

therefore i searched the internet for stuff relating to that. i found the following code which is kinda useful.

Whenever I upload that stuff i get the following errors:
Parse error: parse error, unexpected T_VARIABLE in /kunden/giselbrecht.org/webseiten/share/share2/store.php3 on line 28

Hopefully some of you guys can help me out on that, and save my day,



// store.php3 - by Florian Dittmer <dittmer@gmx.net>
// Example php script to demonstrate the storing of binary files into
// an sql database. More information can be found at http://www.phpbuilder.com/

<head><title>Store binary data into SQL Database</title></head>

// code that will be executed if the form has been submitted:

if ($submit) {

//connect to db
$host = "localhost";
$user = "db34711_3";
$pass = "philgise";
$database = "db34711_3";

$db = mysql_connect("$host","$user","$pass") or die ("Keine Verbindung moeglich");
mysql_select_db("$database",$db) or die ("Datenbank fehlt");

$data = addslashes(fread(fopen($form_data,"r"), filesize($form_data)));

****$result = mysql_query("INSERT INTO binary_data (description,bin_data,filename,filesize,filetype) VALUES ('$form_description','$data','$form_data_name','$form_data_size','$form_data_type')");

****$id = mysql_insert_id();
****print "<p>This file has the following Database ID: <b>$id</b>";

****mysql_close() or die ("Datenbank");

} else {

****// else show the form to submit new data:

****<form method="post" action="<?php echo $PHP_SELF; ?>" enctype="multipart/form-data">
****File Description:<br>
****<input type="text" name="form_description"**size="40">
****<input type="hidden" name="MAX_FILE_SIZE" value="1000000">
****<br>File to upload/store in database:<br>
****<input type="file" name="form_data"**size="40">
****<p><input type="submit" name="submit" value="submit">





11-22-2006, 01:50 AM
please edit your post and add [ php] and [/php] tags for clarity, take the space out of the first tag.

then do a search on unexpected T_VARIABLE either here or on google and you will have the problem explained.