...

View Full Version : Problem with my HyperlinkUrl parameter



AlexanderBlade
11-21-2006, 10:25 PM
Hi everyone, I have a problem with my HyperlinkUrl. I am trying to send this parameter

<%# DataBinder.Eval(Container.DataItem, "Name")%>

to my javascript function.

This works: NavigateUrl='JavaScript:openPopup("largerImage.aspx?name=Airbrushing")'

This does not work:

NavigateUrl='JavaScript:openPopup("largerImage.aspx?name=<%# DataBinder.Eval(Container.DataItem, "Name")%> ")'

I canít figure out the difference. I am a beginner so I canít figure out what to do to solve it. Please help.

AlexanderBlade

nikkiH
11-22-2006, 03:12 PM
It's an embedded quotes issue. You have double quotes twice inside each other, so it doesn't know what you really meant.

(use the BB code CODE button so it formats your code nicely when you post code)

Try this:


NavigateUrl='JavaScript:OpenPopup("largerImage.aspx?name=<%# DataBinder.Eval(Container.DataItem, \"Name\")%> ")'


Or this


NavigateUrl='JavaScript:OpenPopup("largerImage.aspx?name='+<%# DataBinder.Eval(Container.DataItem, "Name")%>+' ")'

AlexanderBlade
11-22-2006, 10:54 PM
Thanks, I tried the first one it worked fine. Thank you so much!

One more question. You mentioned a BB code CODE button. Where do I find it and do you know if there is a sight that may show me how to use it?

Thank you so much for helping me. Iíve been trying to find a solution for this problem for at least one month.

Thanks again!

vinyl-junkie
11-24-2006, 02:07 PM
One more question. You mentioned a BB code CODE button. Where do I find it and do you know if there is a sight that may show me how to use it?
BB code buttons are above the message reply dialog box. The one you want to pay closest attention to is the # icon, which encloses code within code tags and sets it apart from the rest of your post.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum