...

View Full Version : embeded windows media problem (next - play)



popopopo
11-18-2006, 06:14 PM
Hi,
i have some sort of a problem...
i embeded windows media player into a html page.
i set the autostart to 0.



<OBJECT id='mediaPlayer' width="320" height="310"
classid='CLSID:22d6f312-b0f6-11d0-94ab-0080c74c7e95'
codebase='http://activex.microsoft.com/activex/controls/ mplayer/en/nsmp2inf.cab#Version=5,1,52,701'
standby='Loading Microsoft Windows Media Player components…' type='application/x-oleobject'>
<param name='fileName' value="http://www.site.com/list.asx">
<param name='animationatStart' value='1'>
<PARAM NAME="EnableContextMenu" VALUE="0">
<param name='transparentatStart' value='0'>
<param name='autoStart' value='0'>
<param name='ShowControls' value='1'>
<param name='ShowDisplay' value='0'>
<param name='ShowStatusBar' value='1'>
<param name='loop' value='0'>
<EMBED type='application/x-mplayer2'
pluginspage='http://microsoft.com/windows/mediaplayer/ en/download/'
id='mediaPlayer' name='mediaPlayer' displaysize='4' autosize='0'
EnableContextMenu='0' bgcolor='darkblue' showcontrols='1' showtracker='1'
showdisplay='0' showstatusbar='1' videoborder3d='0' width="320" height="310"
src="http://www.site.com/list.asx" autostart='0' designtimesp='5311' loop='0'>
</EMBED>
</OBJECT>


this is the normal asx:

<ASX VERSION="3.0">
<TITLE>LIST</TITLE>
<ENTRY>
<title>NAME</title>
<REF HREF="http://www.site.com/file0.wmv"/>
</ENTRY>
<ENTRY>
<title>NAME2</title>
<REF HREF="http://www.site.com/file1.wmv"/>
</ENTRY>
<ENTRY>
<title>NAME3</title>
<REF HREF="http://www.site.com/file2.wmv"/>
</ENTRY>
</ASX>

the problem is that i need to click "next" & then "play" if i want to play the next video...
when i click "next" it go next & stop. so i need to click "play".
only if i set autostart to 1 when i click "next" it auto will play the next video.
BUT i don't want it to auto play when the page is first loaded... :confused:

how to make the media NOT to play when the page is first loaded & go to the next video by clicking only the next button (as it should be)?

thanks

chaser7016
11-18-2006, 06:40 PM
Try -1 to stop AutoStart

popopopo
11-18-2006, 07:24 PM
Try -1 to stop AutoStart

-1 set autoStart to an "ON" postion...
i need it to be OFF :(



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum