Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 3 of 3
  1. #1
    Senior Coder NancyJ's Avatar
    Join Date
    Feb 2005
    Location
    Bradford, UK
    Posts
    3,174
    Thanks
    19
    Thanked 66 Times in 65 Posts

    Apache2 + Webmin

    I'm having a problem with webmin and apache 2. I changed all the module configuration options to apache2 and mostly it seems to be working, except when I try to use webmin to start or stop apache. It always says apache isnt running.
    The command I told it to issue is apache2 -k start, which works fine when I type it into the console.
    Code:
    Failed to start apache : Apache does not appear to be running :
    
    Usage: /etc/init.d/apache2 start|stop|restart|reload|force-reload

  • #2
    Regular Coder
    Join Date
    Feb 2005
    Location
    UK
    Posts
    133
    Thanks
    0
    Thanked 0 Times in 0 Posts
    In the webmin apache config, does it have the correct location for the PID file?

  • #3
    New to the CF scene
    Join Date
    Jul 2008
    Location
    Serbia
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi, I have some question regarding Webmin so I'll ask here, don't want to open new thread (came to this thread via search, had same problem as NancyJ, which I solved meanwhile).

    Anyway, I started using some dedicated server and I have Webmin as control panel. There is also Apache that I turned on and it worked.

    But since I didn't find anything to access server via ftp, I searched on net and understood that I need to install some module for it on Webmin.

    In list of inactive modules I found Proftpd and install it. And then I made problem: somewhere in Webmin where is administration of users I edited user "ftp" since when logging I went to directory /var/ftp and I wanted to go to /var/www/html.

    But when I changed accessing directory from /var/ftp to /var/www/html it didn't work so I again moved to /var/ftp. After that I again couldn't access but noticed in file manager under Webmin that content of /var/www was moved to /var/ftp and previous content of /var/ftp disappeared. I created new directory www in /var and copied in file manager content from /var/ftp but again when access from public address I receive error 403 forbidden. I rebooted system but again same.

    So could someone help me with this? I'll provide you with more informations if it is needed.
    Thanks in advance


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •