Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Page 1 of 5 123 ... LastLast
Results 1 to 15 of 61
  1. #1
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts

    Apache will not start

    Okay guys, I have a problem that I can't seem to figure out with Apache.
    I used this guys http://webdevcodex.com/tutorial-inst...#installapache tutorial and yesterday my apache was running cause it had the green indicator. After I did this tutorial, the indicator is now red. I tried to manaully start it but no no avail. It says "The requested operation has failed. I'm not sure what to do here. Any help will be appreciated.

  • #2
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,978
    Thanks
    4
    Thanked 2,659 Times in 2,628 Posts
    What do the apache error logs indicate as the problem?

  • Users who have thanked Fou-Lu for this post:

    zigvab75 (02-29-2012)

  • #3
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    I think I found the error log. I'm still new to Apache and don't know much about it.
    Starting the Apache2.2 service
    The Apache2.2 service is running.
    ] Apache/2.2.22 (Win32) configured -- resuming normal operations
    [Thu Feb 16 13:04:05 2012] [notice] Server built: Jan 28 2012 11:16:39
    [Thu Feb 16 13:04:05 2012] [notice] Parent: Created child process 6364
    [Thu Feb 16 13:04:05 2012] [notice] Child 6364: Child process is running
    [Thu Feb 16 13:04:06 2012] [notice] Child 6364: Acquired the start mutex.
    [Thu Feb 16 13:04:06 2012] [notice] Child 6364: Starting 64 worker threads.
    [Thu Feb 16 13:04:06 2012] [notice] Child 6364: Starting thread to listen on port 80.
    [Thu Feb 16 13:05:12 2012] [error] [client 127.0.0.1] File does not exist: C:/webdev/apache/htdocs/favicon.ico
    [Thu Feb 16 13:05:44 2012] [error] [client 127.0.0.1] File does not exist: C:/webdev/apache/htdocs/favicon.ico
    [Thu Feb 16 13:13:24 2012] [error] [client 127.0.0.1] File does not exist: C:/webdev/apache/htdocs/favicon.ico
    [Thu Feb 16 13:17:00 2012] [notice] Parent: Received shutdown signal -- Shutting down the server.
    [Thu Feb 16 13:17:00 2012] [notice] Child 6364: Exit event signaled. Child process is ending.
    [Thu Feb 16 13:17:01 2012] [notice] Child 6364: Released the start mutex
    [Thu Feb 16 13:17:02 2012] [notice] Child 6364: All worker threads have exited.
    [Thu Feb 16 13:17:02 2012] [notice] Child 6364: Child process is exiting
    [Thu Feb 16 13:17:02 2012] [notice] Parent: Child process exited successfully.
    [Thu Feb 16 13:26:09 2012] [notice] Apache/2.2.22 (Win32) configured -- resuming normal operations
    [Thu Feb 16 13:26:09 2012] [notice] Server built: Jan 28 2012 11:16:39
    [Thu Feb 16 13:26:09 2012] [notice] Parent: Created child process 2168
    [Thu Feb 16 13:26:09 2012] [notice] Child 2168: Child process is running
    [Thu Feb 16 13:26:09 2012] [notice] Child 2168: Acquired the start mutex.
    [Thu Feb 16 13:26:09 2012] [notice] Child 2168: Starting 64 worker threads.
    [Thu Feb 16 13:26:09 2012] [notice] Child 2168: Starting thread to listen on port 80.
    [Thu Feb 16 13:50:43 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 13:55:54 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 13:56:44 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 13:57:14 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 13:57:43 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 13:58:20 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 18:17:57 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 18:18:44 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 18:19:12 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 18:19:44 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Thu Feb 16 18:20:14 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Fri Feb 17 11:50:53 2012] [error] [client 127.0.0.1] File does not exist: C:/webdev/apache/htdocs/layout-two-liquid-background.gif, referer: http://localhost/
    [Fri Feb 17 12:38:34 2012] [notice] Parent: Received shutdown signal -- Shutting down the server.
    [Fri Feb 17 12:38:34 2012] [notice] Child 2168: Exit event signaled. Child process is ending.
    [Fri Feb 17 12:38:35 2012] [notice] Child 2168: Released the start mutex
    [Fri Feb 17 12:38:36 2012] [notice] Child 2168: All worker threads have exited.
    [Fri Feb 17 12:38:36 2012] [notice] Child 2168: Child process is exiting
    [Fri Feb 17 12:38:37 2012] [notice] Parent: Child process exited successfully.
    [Fri Feb 24 17:59:46 2012] [notice] Apache/2.2.22 (Win32) configured -- resuming normal operations
    [Fri Feb 24 17:59:46 2012] [notice] Server built: Jan 28 2012 11:16:39
    [Fri Feb 24 17:59:46 2012] [notice] Parent: Created child process 2124
    [Fri Feb 24 17:59:47 2012] [notice] Child 2124: Child process is running
    [Fri Feb 24 17:59:47 2012] [notice] Child 2124: Acquired the start mutex.
    [Fri Feb 24 17:59:47 2012] [notice] Child 2124: Starting 64 worker threads.
    [Fri Feb 24 17:59:47 2012] [notice] Child 2124: Starting thread to listen on port 80.
    [Tue Feb 28 09:26:01 2012] [warn] (OS 64)The specified network name is no longer available. : winnt_accept: Asynchronous AcceptEx failed.
    [Tue Feb 28 13:31:43 2012] [warn] pid file C:/webdev/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
    [Tue Feb 28 13:31:43 2012] [notice] Apache/2.2.22 (Win32) configured -- resuming normal operations
    [Tue Feb 28 13:31:43 2012] [notice] Server built: Jan 28 2012 11:16:39
    [Tue Feb 28 13:31:43 2012] [notice] Parent: Created child process 1600
    [Tue Feb 28 13:31:43 2012] [notice] Child 1600: Child process is running
    [Tue Feb 28 13:31:43 2012] [notice] Child 1600: Acquired the start mutex.
    [Tue Feb 28 13:31:43 2012] [notice] Child 1600: Starting 64 worker threads.
    [Tue Feb 28 13:31:44 2012] [notice] Child 1600: Starting thread to listen on port 80.
    [Wed Feb 29 10:42:38 2012] [notice] Parent: Received restart signal -- Restarting the server.
    [Wed Feb 29 10:42:38 2012] [notice] Child 1600: Exit event signaled. Child process is ending.
    [Wed Feb 29 10:42:39 2012] [notice] Child 1600: Released the start mutex
    httpd.exe: Syntax error on line 120 of C:/webdev/apache/conf/httpd.conf: Cannot load C:/server/php/php5apache2_2.dll into server: The specified module could not be found. [Wed Feb 29 10:42:40 2012] [notice] Child 1600: All worker threads have exited.
    [Wed Feb 29 10:42:40 2012] [notice] Child 1600: Child process is exiting
    Is that the problem maybe?
    Last edited by zigvab75; 02-29-2012 at 05:25 PM.

  • #4
    New Coder
    Join Date
    Nov 2011
    Posts
    88
    Thanks
    4
    Thanked 26 Times in 26 Posts
    Comment out line 120 of C:/webdev/apache/conf/httpd.conf and see ;-)

  • Users who have thanked leslie.jones for this post:

    zigvab75 (02-29-2012)

  • #5
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    Now when you say "comment out" do you mean to use the <If module> </Ifmodule>?
    Sorry, I'm real noob at this.

  • #6
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    I took a guess and used # on line 120 and changed "server" to "webdev" because I made webdev my folder-name and not server. I went through each line in crimson editor to see if there were more "server" paths that should be changed to "webdev" and found none. I restarted apache and tried to start it again but my indicator is still red.

  • #7
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    Would it be a better idea to uninstall apache and reinstall it and instead of using C:\webdev use C:\server instead?

  • #8
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,978
    Thanks
    4
    Thanked 2,659 Times in 2,628 Posts
    I wouldn't bother.
    What's the path to the PHP apache hook? Is it under C:/server/php/php5apache2_2.dll or is it under C:\Webdev\*?

  • Users who have thanked Fou-Lu for this post:

    zigvab75 (03-01-2012)

  • #9
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    Thank you for the response, Fou-lu. The path is C:\webdev\php\php5apache2_2.dll

  • #10
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,978
    Thanks
    4
    Thanked 2,659 Times in 2,628 Posts
    Then you need to modify your configuration in httpd.conf. Its pointing at the wrong directory.

  • Users who have thanked Fou-Lu for this post:

    zigvab75 (03-01-2012)

  • #11
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    Okay, is this what it should look like?
    #LoadModule php5_module "C:/webdev/php/php5apache2_2.dll"

  • #12
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    Okay, I got it figured out.
    It was like this #LoadModule php5_module "C:/webdev/php/php5apache2_2.dll"
    PHPIniDir "C:/webdev/php"

    Then I changed it to #LoadModule php5_module "C:/webdev/php/php5apache2_2.dll"
    #PHPIniDir "C:/webdev/php"
    The red "#" was missing and I put it in there and now my indicator is green again.
    Happy I am. =P

    Thank you, Fou-lu, for the help.

  • #13
    New Coder
    Join Date
    Feb 2012
    Posts
    41
    Thanks
    31
    Thanked 2 Times in 2 Posts
    Unfortunately I have a new problem, though. When I tried to test the localhost I got a forbidden page. Is there something I need to do to fix that?

  • #14
    New Coder
    Join Date
    Nov 2011
    Posts
    88
    Thanks
    4
    Thanked 26 Times in 26 Posts
    Quote Originally Posted by zigvab75 View Post
    Unfortunately I have a new problem, though. When I tried to test the localhost I got a forbidden page. Is there something I need to do to fix that?
    What do the logs say? check access & error logs.

  • Users who have thanked leslie.jones for this post:

    zigvab75 (03-02-2012)

  • #15
    God Emperor Fou-Lu's Avatar
    Join Date
    Sep 2002
    Location
    Saskatoon, Saskatchewan
    Posts
    16,978
    Thanks
    4
    Thanked 2,659 Times in 2,628 Posts
    Can you access a file directly by name? Sounds to me like you are going to the directory and Indexes are not available. You can add it in by finding the <Directory> block corresponding to the root, and add Options Indexes or Indexes to an existing Options config. Restart and try again.

  • Users who have thanked Fou-Lu for this post:

    zigvab75 (03-02-2012)


  •  
    Page 1 of 5 123 ... LastLast

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •