Hi I always wondered why there where 301 and 302 in my awstat when I dont have any in my hataccess.

Well I just noticied that my host blocked sites that were in spamhaus blacklisting using a 406 and as the 406 error page did not exist it got an 404.
Well I complained about it.
And suddenly there were no more 406, so I started to look in my rawlog file.
and I can see these strange entries:
Code:
220.113.9.168 - - [22/Jan/2012:00:40:03 -0700] "GET /bookingform.php?propiedad=Marbella_del_Mar_5 HTTP/1.0" 200 9457 "-" "Mozilla/5.0 (Windows NT 5.1; U; en) Opera 8.01"
220.113.9.168 - - [22/Jan/2012:00:40:05 -0700] "POST /bookingform.php HTTP/1.0" 302 142 "http://www.mysite.com/bookingform.php?propiedad=Marbella_del_Mar_5" "Mozilla/5.0 (Windows NT 5.1; U; en) Opera 8.01"
220.113.9.169 - - [22/Jan/2012:00:40:07 -0700] "GET /pages/formdone_casas.htm HTTP/1.0" 404 - "http://www.mysite.com/bookingform.php?propiedad=Marbella_del_Mar_5" "Mozilla/5.0 (Windows NT 5.1; U; en) Opera 8.01"


220.181.108.139 - - [22/Jan/2012:03:08:43 -0700] "GET /thumbnails/el_paraiso_1.jpg HTTP/1.1" 301 269 "-" "Baiduspider-image+(+http://www.baidu.com/search/spider.htm)"
220.181.108.161 - - [22/Jan/2012:03:08:47 -0700] "GET /thumbnails/el_paraiso_1.jpg HTTP/1.1" 404 1834 "-" "Baiduspider-image+(+http://www.baidu.com/search/spider.htm)"


85.26.155.200 - - [22/Jan/2012:11:04:59 -0700] "GET / HTTP/1.1" 404 - "-" "Mozilla/5.0 (iPad; CPU OS 5_0_1 like Mac


107.22.57.15 - - [17/Jan/2012:17:40:38 -0700] "GET /pages/formdone_casas.htm HTTP/1.1" 200 886 "http://www.mysite.com/pages/formdone_casas.htm" "Opera/9.01 (Windows NT 5.1; U; en)"
174.143.26.96 - - [17/Jan/2012:17:40:43 -0700] "GET /pages/formdone_casas.htm HTTP/1.0" 404 - "http://www.mysite.com/pages/formdone_casas.htm" "Opera/9.01 (Windows NT 5.1; U; en)"
210.101.131.231 - - [17/Jan/2012:17:40:51 -0700] "GET /pages/formdone_casas.htm HTTP/1.0" 404
It looks like the host serves sometimes an 301 or 302 that then get a 404 and sometimes inclusive a 404 directly.

The image from baiduspider does not exists, but it gets a 301,
and the hit from 85.26.155.200 looks like a direct hit to my homepage to me and it got an 404 error.

Is it normal practice to block ips in spamhause this way?