Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Oct 2011
    Posts
    65
    Thanks
    1
    Thanked 0 Times in 0 Posts

    urgent, problem with host, max memory usage

    Hi, not sure this should go here.
    I am having troubbles with my shared host. On the 6th january they migrated my site to another server.
    On the 13th when I wanted to enter my password protected directory It got an Error 500 page, also I had problems with emails not working. This I reported to the host and cpanel had it fixed some hours later. Some days later I reported that awstat gives stats to low and mentioned that sometimes when I opened my chat I see Internal server error and I have to refresh the page and then its ok.

    Yesterday morning at 8.00 having breakfast, I opened chat and had internal server error and had to refresh several times to get it ok.
    I went directly to my error log and had errors like this:
    [Wed Jan 18 00:01:43 2012] [error] [client 80.174.72.31] File does not exist: /home/mysite/public_html/500.shtml, referer: http://www.myweb.com/chat/live.php
    [Wed Jan 18 00:01:43 2012] [error] [client 80.174.72.31] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/mysite/public_html/chat/admin_connect.php, referer: http://www.myweb.com/chat/live.php
    also like this wich is a webpage and not the chat but loading the chat image:
    [Wed Jan 18 00:19:42 2012] [error] [client 83.49.242.50] File does not exist: /home/mysite/public_html/500.shtml, referer: http://www.myweb.com/espanol/banana_...inea_playa.htm
    [Wed Jan 18 00:19:42 2012] [error] [client 83.49.242.50] (12)Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp for /home/mysite/public_html/chat/image.php, referer: http://www.myweb.com/espanol/banana_...inea_playa.htm
    [Wed Jan 18 00:18:00 2012] [error] [client 89.85.181.189] File does not exist: /home/mysite/public_html/500.shtml, referer: http://www.myweb.com/

    I reported this to the host, and of course it was due of the chat taking a lot of memory.

    After studying resourge usage for last 30 days in cpanel I was able to prove that I reached max memory usage often since 13th january (same day as the other 500 error but) and it also happened at nighttime when my pc was shut down and the chat pages was closed, its true it takes cpu and memory, but not that much.

    Anyway he insist is not a bug a tell me to hire a webdeveloper......

    Anyway, Can anybody tell me if its posible to have such a low average memory usage and such a high max memory usage.
    Below you can see one entry for the 6th january and one for 19th january with almost same average usage but the difference in max is more than 5 times higher:

    Code:
    From             To    aCPU   mCpu   aEP   mEP   lEP   aMEM   mMEM   lMEM   MemF   MepF 
    01-19 07:00 01-19 08:00   0   10      0   1      20    2.2M 384.0M  384.0M    3     0 
    01-07 11:00 01-07 12:00   0   10      0   2      20    1.9M 70.6M 384.0M    0      0
    
    aMEM                   : Average Memory Usage
    mMEM                   : Max Memory Usage
    lMEM                   : Memory Limit
    MemF                   : Out Of Memory Faults
    Thanks in advance
    Also I am getting some errors 406 and think its a bit strange.

  • #2
    New Coder
    Join Date
    Oct 2011
    Posts
    65
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Also If somebody can explain what´s taking memory usage, for exampel images takes memory usage or only bandwith?


  •  

    Tags for this Thread

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •