Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    JAG
    JAG is offline
    New Coder
    Join Date
    Feb 2011
    Posts
    63
    Thanks
    24
    Thanked 0 Times in 0 Posts

    Question http://localhost/xampp/ "Object not found!"

    Hi guys, I use XAMPP to develop my site locally before uploading it to our remote server. I recently added a virtual host entry in my httpd-vhosts.conf file to run my site locally:

    <VirtualHost *:80>
    ServerName das
    ServerAdmin webmaster@das.com
    DocumentRoot /Websites/das.com/public
    <Directory "/Websites/das.com/public">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>

    However, now when I try to use http://localhost/xampp/, it tells me Object not found!

    How can I get both my new virtual host and the XAMPP setup page working correctly, without having to remove my virtual host entry and reloading Apache to be able to view the http://localhost/xampp/ page?

  • #2
    JAG
    JAG is offline
    New Coder
    Join Date
    Feb 2011
    Posts
    63
    Thanks
    24
    Thanked 0 Times in 0 Posts
    Oops, got the answer. Turns out I needed to create a virtual host entry for the localhost as well:

    <VirtualHost *:80>
    ServerName localhost
    ServerAdmin webmaster@das.com
    DocumentRoot /xampp/htdocs
    <Directory "/xampp/htdocs">
    Options Indexes FollowSymLinks Includes ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •