Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 4 of 4
  1. #1
    Regular Coder MrBiggZ's Avatar
    Join Date
    Apr 2005
    Location
    Indianapolis IN
    Posts
    259
    Thanks
    37
    Thanked 0 Times in 0 Posts

    Unhappy Getting 'You don't have permission to access /' and I'm confused!

    Greetings!

    I'm getting somewhere with this. Slowly but now I'm getting

    Forbidden

    You don't have permission to access / on this server.
    when I access either the default server which has an alias of 'myserver' or 'mrbiggz.kicks-***.net' Those two will give me a forbidden message. The other two 'phpmyadmin' and 'mrbiggz.dyndns.org' function normally.

    Here's my directory tree from my htdocs root

    Directory of d:\www

    07/10/2011 05:16 PM <DIR> .
    07/10/2011 05:16 PM <DIR> ..
    07/09/2011 11:16 PM <DIR> mrbiggz.dyndns.org
    07/10/2011 05:13 PM <DIR> mrbiggz.kick-***.net
    07/10/2011 02:05 PM <DIR> pma
    These are my virtual servers as of this problem

    Code:
    <Virtualhost *:80>
    	DocumentRoot "d:/www"
    	ServerName myserver
    	<Directory "d:/www/myserver.dev">
    		AllowOverride All
    		Options Indexes FollowSymLinks
    		Order allow,deny
    		Allow from all
    	</Directory>
    </virtualhost>
    
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    	DocumentRoot "d:/www/pma"
    	ServerName phpmyadmin
        ErrorLog "logs/phpmyadmin-error.log"
        CustomLog "logs/phpmyadmin-access.log" combined
    	DirectoryIndex index.php index.html index.htm index.shtml
    	<Directory "d:/www/myserver.dev/pma">
    		Options Indexes FollowSymLinks Includes ExecCGI MultiViews
    		AllowOverride All
    		Order allow,deny
    		Allow from all
    	</Directory>
    </VirtualHost>
    
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    	DocumentRoot "d:/www/mrbiggz.dyndns.org"
    	ServerName mrbiggz.dyndns.org
        ErrorLog "logs/mrbiggz.dyndns.org-error.log"
        CustomLog "logs/mrbiggz.dyndns.org-access.log" combined
    	DirectoryIndex index.php index.html index.htm index.shtml
    	<Directory "d:/www/mrbiggz.dyndns.org">
    		Options Indexes FollowSymLinks Includes ExecCGI MultiViews
    		AllowOverride All
    		Order allow,deny
    		Allow from all
    	</Directory>
    </VirtualHost>
    
    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    	DocumentRoot "d:/www/mrbiggz.kick-***.net"
    	ServerName mrbiggz.kick-***.net
        ErrorLog "logs/mrbiggz.kick-***.net-error.log"
        CustomLog "logs/mrbiggz.kick-***.net-access.log" combined
    	DirectoryIndex index.php index.html index.htm index.shtml	
    	<Directory "d:/www/mrbiggz.kick-***.net">
    		Options Indexes FollowSymLinks Includes ExecCGI MultiViews
    		AllowOverride All
    		Order allow,deny
    		Allow from all
    	</Directory>
    </VirtualHost>
    I've attached my httpd.conf and httpd-vhosts.conf files to this thread
    httpd.txt
    httpd-vhosts.txt

    I hope somebody can help me! Please?!
    Last edited by MrBiggZ; 07-10-2011 at 10:32 PM. Reason: Changes to my problem
    “No matter how slick the demo is in rehearsal, when you do it in front of a live audience, the probability of a flawless presentation is inversely proportional to the number of people watching, raised to the power of the amount of money involved.” ~ Mark Gibbs

  • #2
    Super Moderator Inigoesdr's Avatar
    Join Date
    Mar 2007
    Location
    Florida, USA
    Posts
    3,638
    Thanks
    2
    Thanked 404 Times in 396 Posts
    Does the directory have an index file in it? Check your error log to see what the specific problem is.

  • #3
    Regular Coder MrBiggZ's Avatar
    Join Date
    Apr 2005
    Location
    Indianapolis IN
    Posts
    259
    Thanks
    37
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Inigoesdr View Post
    Does the directory have an index file in it? Check your error log to see what the specific problem is.
    For server 'myserver' No
    For server 'phpmyadmin' Yes
    For server 'mrbiggz.dyndns.org No (name is index1.html)
    For server 'mrbiggz.kick-***.net Yes

    myserver and mrbiggz.kick-***.net are the ones giving me trouble. The log files for mrbiggz.kick-***.net did not create anything it was blank. The error log for the server have a few entries.

    httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.101 for ServerName
    [Sun Jul 10 20:40:49 2011] [notice] Apache/2.2.19 (Win32) PHP/5.2.17 configured -- resuming normal operations
    [Sun Jul 10 20:40:49 2011] [notice] Server built: May 20 2011 17:39:35
    [Sun Jul 10 20:40:49 2011] [notice] Parent: Created child process 3192
    httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.101 for ServerName
    httpd.exe: Could not reliably determine the server's fully qualified domain name, using 192.168.1.101 for ServerName
    [Sun Jul 10 20:40:50 2011] [notice] Child 3192: Child process is running
    [Sun Jul 10 20:40:50 2011] [notice] Child 3192: Acquired the start mutex.
    [Sun Jul 10 20:40:50 2011] [notice] Child 3192: Starting 64 worker threads.
    [Sun Jul 10 20:40:50 2011] [notice] Child 3192: Starting thread to listen on port 80.
    [Sun Jul 10 20:42:18 2011] [error] [client 127.0.0.1] client denied by server configuration: D:/www/
    [Sun Jul 10 20:42:49 2011] [error] [client 127.0.0.1] client denied by server configuration: D:/www/
    [Sun Jul 10 20:42:49 2011] [error] [client 127.0.0.1] client denied by server configuration: D:/www/favicon.ico
    Note: I shut down the server, trashed all the logs and then started the server back up.

    @ 20:42:18 is when I tried to access 'myserver'
    @ 20:42:49 is when I tried to access 'mrbiggz.kicks-***.net'

    This is weird!

    Whooops! I took a peek at the virtual conf file again before I posted this. In the 'myserver' configuration I had
    Code:
    <Directory "d:/www/myserver.dev">
    when it should have been
    Code:
    <Directory "d:/www">
    I corrected that and restarted the server. Now when I hit 'myserver' I get this:
    Index of /

    mrbiggz.dyndns.org/
    mrbiggz.kick-***.net/
    pma/
    BUT

    When I hit 'mrbiggz.kick-***.net' I get the same response as above.
    Again .. weird!
    “No matter how slick the demo is in rehearsal, when you do it in front of a live audience, the probability of a flawless presentation is inversely proportional to the number of people watching, raised to the power of the amount of money involved.” ~ Mark Gibbs

  • #4
    Regular Coder MrBiggZ's Avatar
    Join Date
    Apr 2005
    Location
    Indianapolis IN
    Posts
    259
    Thanks
    37
    Thanked 0 Times in 0 Posts

    Thumbs up Solved

    Ok ..

    Here's what solved it! An 's' .. that's it! Were things said kick should have been kicks!

    It took a good night sleep and not staring at it for hours trying to figure out WTF?!

    Bah!

    Thanks for your help Inigoesdr!
    “No matter how slick the demo is in rehearsal, when you do it in front of a live audience, the probability of a flawless presentation is inversely proportional to the number of people watching, raised to the power of the amount of money involved.” ~ Mark Gibbs


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •