Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    New Coder
    Join Date
    Aug 2010
    Posts
    18
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Unhappy Help with FollowSymlinks ?

    Hello members of CF,

    i wonder if someone can help,

    I have a shopping cart script which uses FollowSymlinks in a .htaccess file
    to generate dynamic urls for the product pages and the .htaccess file
    is located in the root directory.

    the problem im having is when
    trying to add a additional payment processor code to the shopping cart script
    in the admin area.

    When adding the payment processor form code to the merchant section in the admin area, it seems the .htaccess file is conflicting with the external payment processor form code causing the form not to render because the .htaccess file is adding an additional slashes to the payment processor form code.

    This is how the payment processor form code is rendering on the site

    Payment processor form code
    Code:
    <form action=\"https://sci.libertyreserve.com/en\" method=\"GET\">
    <input type=\"hidden\" name=\"lr_acc\" value=\"U6016045\">
    <input type=\"hidden\" name=\"lr_amnt\" value=\"0.01\">
    <input type=\"hidden\" name=\"lr_currency\" value=\"LRUSD\">
    <input type=\"hidden\" name=\"lr_success_url\" value=\"http://www.myshop.com/thanks.php\">
    <input type=\"hidden\" name=\"lr_success_url_method\" value=\"POST\">
    <input type=\"hidden\" name=\"lr_fail_url\" value=\"http://www.myshop.com/\">
    <input type=\"hidden\" name=\"lr_fail_url_method\" value=\"POST\">
    <input type=\"submit\" />
    </form>
    Notice all the additional slashes ? this is causing the form not to render or
    to work !

    Now i know this .htaccess file has something to do with the problem
    but i don't have a clue on how to resolve this problem.

    .htacces file
    Code:
    Options +FollowSymlinks
    RewriteEngine on
    RewriteRule ^(.*)\.html$ viewdetails.php?itemno=$1 [NC]
    Thank you

  • #2
    Super Moderator Inigoesdr's Avatar
    Join Date
    Mar 2007
    Location
    Florida, USA
    Posts
    3,638
    Thanks
    2
    Thanked 404 Times in 396 Posts
    Quote Originally Posted by inta74 View Post
    it seems the .htaccess file is conflicting with the external payment processor form code causing the form not to render because the .htaccess file is adding an additional slashes to the payment processor form code.

    ...

    Now i know this .htaccess file has something to do with the problem
    but i don't have a clue on how to resolve this problem.
    Nope. That .htaccess file is not modifying your page output. The cause is almost certainly poorly written PHP.


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •