Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 5 of 5
  1. #1
    New Coder
    Join Date
    Feb 2009
    Posts
    40
    Thanks
    15
    Thanked 0 Times in 0 Posts

    Custom 404 not working

    Hi,

    I have this line of code in my .htaccess:
    ErrorDocument 404 /pages/error/index.php

    But this just doesn't work; I'm still getting the normal 404 error. Any idea what I'm doing wrong here?

    Thank you!

  • #2
    Super Moderator Inigoesdr's Avatar
    Join Date
    Mar 2007
    Location
    Florida, USA
    Posts
    3,642
    Thanks
    2
    Thanked 405 Times in 397 Posts
    Does it say "Additionally, a ___________ error was encountered while trying to use an ErrorDocument"?

  • #3
    New Coder
    Join Date
    Feb 2009
    Posts
    40
    Thanks
    15
    Thanked 0 Times in 0 Posts
    Yes:
    "Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    Is this a problem?

  • #4
    Super Moderator Inigoesdr's Avatar
    Join Date
    Mar 2007
    Location
    Florida, USA
    Posts
    3,642
    Thanks
    2
    Thanked 405 Times in 397 Posts
    Yes, that means the path you're using to point to the 404 file is incorrect.

  • #5
    New Coder
    Join Date
    Feb 2009
    Posts
    40
    Thanks
    15
    Thanked 0 Times in 0 Posts
    Hey,

    But I checked the path 5 times; it's really correct.

    If I remove the line from the .htaccess, I'm still getting the same error...


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •