Hello and welcome to our community! Is this your first visit?
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    Senior Coder angst's Avatar
    Join Date
    Apr 2004
    Toronto, Ontario
    Thanked 122 Times in 122 Posts

    Question apache router issue?


    I have a strange issue with apache2 ( on ubuntu ), hoping that someone here may be able to shed some light on.

    here's the situation;

    I've got an apache server on my network: ( no firewall )

    I need to connect to make a SOAP call to a server thats on an extension of our network:

    from the console on the apache server I can ping, I can also open up a LYNX ( txt based browser ) to and it connects without an issue, however when I try to connect from apache/php I get "failed to open stream".

    how if I take my web server, put it on the exact same ( physical ) as "" it works no problem.

    so all I can think of is that apache has some kind of routing issue?

    any ideas at all would be a big help at this point!


  2. AdSlot6
  3. #2
    New Coder
    Join Date
    Mar 2010
    Virginia, USA
    Thanked 5 Times in 5 Posts
    Hello Ken,

    What PHP function are you using to make the connection?

    Some functions are sanitized by various php.ini settings - several directives can block remote connectivity for safety reasons, e.g: allow-url-fopen

    Another test is to trying opening a telnet session from to on the port the SOAP server is running. While the IP is accessible, the port may not be.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts