Please Help!

Hi,

This code works on all my domains:

AddHandler shtml server-parsed
ErrorDocument 404 http://www.domain.org
ErrorDocument 403 http://www.domain.org
Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^domain.org [nc]
rewriterule ^(.*)$ http://www.domain.org/$1 [r=301,nc]

Now I just got a new domain called:
http://www.lower-back-tattoo-designs.org
and I got
http://www.lower-back-tattoo-designs-blog.org
(I needed a new domain for it)

I have a reseller account. http://www.lower-back-tattoo-designs.org is the primary domain and http://www.lower-back-tattoo-designs-blog.org is an addon domain.

on http://www.lower-back-tattoo-designs.org this is what I have in my htaccess file:

AddHandler shtml server-parsed
ErrorDocument 404 http://www.lower-back-tattoo-designs.org
ErrorDocument 403 http://www.lower-back-tattoo-designs.org
Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^lower-back-tattoo-designs.org [nc]
rewriterule ^(.*)$ http://www.lower-back-tattoo-designs.org/$1 [r=301,nc]

and it works fine. So error pages http://domain.com, http://domain.com/blarblar - everthing goes to http://www.domain.com

So I have the same in the blog domain:

AddHandler shtml server-parsed
ErrorDocument 404 http://www.lower-back-tattoo-designs-blog.org
ErrorDocument 403 http://www.lower-back-tattoo-designs-blog.org
Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^lower-back-tattoo-designs-blog.org [nc]
rewriterule ^(.*)$ http://www.lower-back-tattoo-designs-blog.org/$1 [r=301,nc]

But now this doesn't do what it should. I get a redirect loop error when I load it in the browser??? But it's exactly the same as the primary domains htaccess file except I changed the URL.

But if I delete the htaccess file out of the blogs domain then:

http://www.lower-back-tattoo-designs-blog.org/blarblar
http://www.lower-back-tattoo-designs...g/404page.html
http://lower-back-tattoo-designs-blog.org
http://lower-back-tattoo-designs-blog.org/hyiascuwu

would all go to http://www.lower-back-tattoo-designs.org

So it's like the primary domains htaccess file is fine. But the blog with wordpress installed on it is reading the primary domains htaccess file. And if I give it its own htaccess file then the server reads them both and I get that redirect loop error when I load the browser. I guess the solution would be to stop the blog domain from reading the primary domains htaccess file, but I don't know how and that just my guess.

I would really appreciate some help on this. I've contacted support but they can't help. I really don't understand why i's not working...

Thanks everyone!

Dan