Hello and welcome to our community! Is this your first visit?
Register
Enjoy an ad free experience by logging in. Not a member yet? Register.
Results 1 to 2 of 2
  1. #1
    Regular Coder
    Join Date
    Aug 2010
    Posts
    405
    Thanks
    17
    Thanked 2 Times in 2 Posts

    slideshow works, not when loaded.

    I have a page with a caroufredsel script in it to show a rotating slideshow. The page works fine on it's own. But I need it to work when loaded into an existing page. I get no errors when I look at console, while loading this page.

    It's easier to just show a link to the site, I believe.

    If you go to this url, and click on the first link in the navigation, you'll see that the slideshow isn't showing when loaded.

    http://www.thewalshgroup.ca/dev/mazenga/site2/

    But go to the page itself, and the slideshow works fine.

    http://www.thewalshgroup.ca/dev/maze...e2/mazenga.php

  • #2
    Regular Coder
    Join Date
    Aug 2010
    Posts
    405
    Thanks
    17
    Thanked 2 Times in 2 Posts
    Phew...

    problem solved.

    After a little hunting around I found out that ajax wasn't loading scripts, because jquery turns the loaded pages scripting to text to account for some issues in IE.

    I was able to solve the problem by adding

    this into the script that loads the page:

    Code:
    $.getScript("js/carousel2.js", function(data, textStatus, jqxhr) {
    	                        	console.log(data); //data returned
    	                        	console.log(textStatus); //success
    	                        	console.log(jqxhr.status); //200
    	                        	console.log('Load was performed.');
    	                        	});


  •  

    Posting Permissions

    • You may not post new threads
    • You may not post replies
    • You may not post attachments
    • You may not edit your posts
    •